Project Won't Load - Hangs on Loading Project


#1

Hello,

My RStudio Cloud project will not load-- it simply hangs on "loading project" for 25 minutes (probably longer, but this is the longest I've waited so far).

No error messages or status codes. It was working around an hour ago.

Project url --
https://rstudio.cloud/project/109414

Thanks for your help.


Can't open project or start new one- "Loading Project"
#2

Update - Just tried to open a different project in a shared class workspace. Got this error:

Task 563188821 failed: Unhandled Exception: HTTP 599: Timeout while connecting

As I said before, all projects were able to be opened about 1 hour 30 minutes ago.


#3

Hello,

I've applied some recovery steps on project 109414. Could you try that project again and see if you're able to open it?

Sean


#4

Hello @seans ,

Tried to reconnect. Still won't load, unfortunately.


#5

@seans

Here's a capture of my dev tools screen when I try to open my project.


#6

Update --

I've tried moving projects to trash and restoring them (as recommended in other threads related to issues such as this), but the problem persists. I can still create new projects, but when I try to open them, they're stuck in the loading screen without giving me any direct error messages.

I also still cannot access any projects within a shared class workspace.


#7

This is occurring on new projects as well? Are there any projects that open successfully for you?


#8

@seans

Correct, new projects will not open either. As of now, it doesn't look like any projects will open for me.


#9

Hi,

From your screen shot it seems like the issue might be browser related. The IDE is connected through an iframe and some browser settings (and browser security plugins) can prohibit post message communication through the iframe.

Could you try either using another browser and see if the behavior is the same?

Sean


#10

@seans

Looks like the issue is persistent across browsers. I tried Firefox, Edge, and Chrome.

Here's some interesting dev tools output from when I tried to load the project in Edge. Not sure if it helps, but figured I should show it anyway.


#11

This is a bit of tricky one...

Thanks for the screen shot it largely confirms that the source of the issue is that the communication between the browser and the IDE through the iframe is being blocked. We have a known similar issue with Safari but unfortunately we are not able to replicate this issue with Chrome, Fire Fox, or Edge (on Windows 10 or OSX).

In older versions of internet explorer there was a setting that prohibit communication through the iframe (which would cause something similar to this). However I have not found analogous settings in the modern desktop version of Chrome, Fire Fox, or Edge. So assuming you are relatively up to date (and not using extremely heavy handed security plugins on all your browsers) that seems unlikely to be the cause.

What type of device are you accessing the website from? If possible do you have another device you could try to rule that out as a source of the issue?

Sean


#12

@seans

I'm pretty sure I just found the issue. My campus just deployed Cisco Umbrella, which is apparently blocking one of the URLs used for accessing projects without throwing an error message directly. The only way to find out that the URL was blocked was to go into the console through Chrome dev tools, find and click that specific URL (which I've highlighted in the below picture), and be brought to a screen notifying the user of the block (which I've also attached). Otherwise, the user would simply see a loading screen that never ended.

I've confirmed this is most likely the issue by trying to open my projects through my mobile hotspot, which worked fine. I'll have to contact my school's IT department immediately to get this whitelisted.

Thanks for your help and responses throughout this issue!


Can't open project or start new one- "Loading Project"
#13

I am also at UW-L. This is my first semester using RStudio Cloud in the classroom, and I was surprised when a number of students were not able to access their projects today, as things have gone very smoothly over the previous few weeks. I am interested in an update regarding ITS. Have you reached out to them about the issue?
I am not sure why this affects some students, but not all? It seems that a work-around is for them to work on their personal computers off campus (or personal hotspot?) if the issue persists on campus?


#14

I just submitted a ticket to the help desk. They may have already taken care of it, but it won't hurt for them to get the message from more than one source!


#15

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.