public link to xaringan slides no longer working

I've created slides using Rmarkdown and xaringan and then uploaded them to github. I've then tried to find the link to display the html using https://{username}.github.io/{folder/subfolder/filename}. This has worked before (e.g., Bad statistics in health and medical research) but is not working today: https://agbarnett.github.io/talks/youngScientists/slides. I've tried Chrome and Firefox.

The build status of your Github pages has an issue:

When did you render the last slides that was working ?

Github has made some changes for Github pages in December:

Also with Github Pages, know that Jekyll will be used by default to build the static website. The error you have in your build is about that. Here, I don't think you need jekyll, so you need to add a .nojekyll file at the root.
https://docs.github.com/en/pages/getting-started-with-github-pages/about-github-pages#static-site-generators

GitHub Pages will use Jekyll to build your site by default. If you want to use a static site generator other than Jekyll, disable the Jekyll build process by creating an empty file called .nojekyll in the root of your publishing source, then follow your static site generator's instructions to build your site locally.

I think by adding this file, this should work again

About your issue in GHA build:

It says that dumped.Rmd as an issue in YAML header that is looked for during Jekyll build, and indeed you don't have one, but you have two lines with --- so maybe this file is creating issue whereas other in repo are not. talks/dumped.Rmd at master · agbarnett/talks · GitHub

Anyway, I don't think you need to have jekyll activated

Many thanks Christophe, I fixed the dumped.Rmd issue and added the empty .nojekyll file, but I still can't see the slides. The last time it worked was back in December 2021, and those slides are still available.

As stated in the github document I linked to, the file should be in the root of the Github Pages website. You have configured github pages to use your Master branch, so the root is the folder above, the root of you project. They say

disable the Jekyll build process by creating an empty file called .nojekyll in the root of your publishing source

This is nothing with R or xaringan just how Github Pages is working.

But as you said, it has worked before even with jekyll used (which I still don't think you need).
So, you should check your actions panes in Github as there will be some information in why the run is failling. I don't see this a deployment for your last commit also:

Maybe check Github pages configuration in settings too.

Happy to help further but I can't see those pane for you.