Pushing Git LFS from RStudio gives error (rpostback-askpass)

rstudio
git
lfs
rpostback-askpass

#1

Working with RStudio desktop 1.1.383 on Windows 10. I can pull and push fine as long as LFS files are not involved, but I get an error when pushing some files that are tracked by LFS:

$ git push
Git LFS: (0 of 5 files) 0 B / 642.00 KB
batch response: Git credentials for REPOSITORY_URL not found:
exec: "rpostback-askpass": executable file not found in %PATH%
error: failed to push some refs to 'REPOSITORY_URL'

(I’ve replaced the actual URL with “REPOSITORY_URL” here).

I get this error both when I click the “Push” button in the IDE and when I type git push on the terminal window in RStudio.

However, if I open a git bash window from Windows Explorer and type git push, I get success:

$ git push
Git LFS: (5 of 5 files) 642.00 KB / 642.00 KB
Counting objects: 14, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (14/14), done.
Writing objects: 100% (14/14), 2.18 KiB | 1.09 MiB/s, done.
Total 14 (delta 6), reused 0 (delta 0)
To REPOSITORY_URL
   9aebf8a..01cbeec  master -> master

I checked in RStudio global options and the git executable is pointing to the correct one (C:/Program Files/git/bin/git.exe). I am connecting to a private gitlab-ce server that I operate, using an https:// URL.

I have git 2.14.2.windows.1 installed (from git-scm.com). This is a new error, and that I have not previously encountered using git-lfs with RStudio on this machine.

I would be grateful if anyone has pointers on how to fix this problem. In the meantime, there is an easy workaround in just opening up a bash window from outside RStudio when I need to pull or push LFS files.


#2

@jonathan-g - For what it’s worth, we noticed some errors and oddities when attempting to use Git-LFS via RStudio Server. Connecting via Putty and running the appropriate git instructions via the terminal seemed to side step this issue. We weren’t able to pin down the problem, but hopefully others will weigh-in as LFS becomes more common.


#3

Awesome, thanks for posting this! Workaround is fine :slight_smile: