Python 3.5 update for shinyapps.io

Currently, when using Python on shinyapps.io, users will see this message:

DEPRECATION: Python 3.5 reached the end of its life on September 13th, 2020. Please upgrade your Python as Python 3.5 is no longer maintained. pip 21.0 will drop support for Python 3.5 in January 2021. pip 21.0 will remove support for this functionality.

RStudio is currently working on upgrading the base Python and this post is for tracking this update.

2 Likes

Hi Everyone:

I just wanted to let everyone know we're looking into upgrading the Python version that is in use on shinyapps.io. We're still investigating the situation, but we hope to have a fix in place next week.

Hi Everyone:

We've completed the image upgrade. All newly deployed shinyapps.io application will now use Python 3.8.

Thanks
-Andy

3 Likes

Hi Everyone:

We're in the final stages of testing our changes to update the version of Python used by shinyapps.io to 3.8. We hope to have these changes available tomorrow or Wednesday.

Thanks
-Andy