Python Deployment Error

Hello,

I keep getting the error message below:

shinyapps.io reported an error (calling /v1/tasks/1264036727?legacy=true): Unhandled Exception: Child Task 1264036728 failed: Error building image: Build exited with non-zero status: 1

The only thing that I can think of after reading the documentation is that I was not using the correct version of Python, so I downloaded 3.9.13 on my laptop and via anaconda. In VSCode, when I used the terminal, it still said I was using 2.7.16, and I kept getting this error.

I selected the 3.9.13 version of Python. When I ran "!python --version" in an .ipynb file that was in the same directory, it communicated that my version was in fact 3.9.13.

My main question is how do I stop getting this? I'm under the impression that I am actually running in 3.9.13, but that may not be the case. Am I running the wrong version? Is there something else that is causing this error that I am missing?