quarto extensions and Quarto Pub

Is it possible to publish a quarto website to Quarto Pub while using quarto extensions?

I've got a website that is using the fontawesome extension available on the Quarto Extensions page. It renders fine locally, and I can upload the rendered site to Netlify. When I use the terminal command quarto publish quarto-pub, I get this error:

Error running filter C:/../Quarto/share/filters/quarto-pre/quarto-pre.lua:
_extensions/quarto-ext/fontawesome/fontawesome.lua:63: attempt to call a nil value (field 'is_format')
stack traceback:
        .../Programs/Quarto/share/filters/quarto-pre/quarto-pre.lua:2943: in function 'callShortcodeHandler'
        .../Programs/Quarto/share/filters/quarto-pre/quarto-pre.lua:3024: in function 'transformShortcodeInlines'

What version of Quarto are you using ? Also what version of the extension ?

There is a recent one you should update to be used with recent Quarto Releases · quarto-ext/fontawesome · GitHub
About how to update: Quarto - Managing Extensions

Thanks @cderv for the tip, and libjohn for posting!
I have the same problem I think. I am working in the latest RStudio Desktop, and using the fontawesome extension 1.1.0 (so the latest one available afaik) when I click on "Render" for the Quarto website, then I get

Error running filter /Applications/RStudio.app/Contents/Resources/quarto/share/filters/quarto-pre/quarto-pre.lua:
../_extensions/quarto-ext/fontawesome/fontawesome.lua:63: attempt to call a nil value (field 'is_format')
stack traceback:
	...Resources/quarto/share/filters/quarto-pre/quarto-pre.lua:2943: in function 'callShortcodeHandler'
	...Resources/quarto/share/filters/quarto-pre/quarto-pre.lua:3024: in function 'transformShortcodeInlines'

I tried to update the extension, but since there is no newer version, that does not help.

Yes this is the latest one that should have the fix for this issue

I am surprised this does not work.

Which is the version of Quarto you have ?

Can you share an example file ?

(and sorry for the delay on this)

I have this exact problem I just installed everything fresh.

Command Line:

$ quarto list extensions
Id                        Version    Contributes
quarto-ext/fontawesome    1.1.0      shortcodes 
quarto-ext/lightbox       0.1.5      filters 

R Info
R version 4.2.2 Patched (2022-11-10 r83330)

> packageVersion("quarto")
[1] ‘’
> packageVersion("fontawesome")
[1] ‘0.5.1’

Oddly enough, Microsoft Teams crashed and I had to reboot my computer. It works now. I've not changed anything on the install.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.