Quarto interactive document publishing error

Kia ora. When trying to publish an interactive Quarto document (any document, including the default) from within RStudio, I get the following error:

(TypeError): Cannot read property 'j' of null

Running the document locally works. Publishing Shiny apps to shinyapps.io works.

Version information:

RStudio 2022.07.1 Build 554
R version 4.2.1 (all packages updated to latest on CRAN)
Windows 11

If anyone can help I would be thankful.

I'm experiencing the same issue trying to publish a static Quarto website.

RStudio 2022.07.1 Build 554
R version 4.2.0
Windows 10

Adding this reply to keep the topic open.

Looks like it is a Windows issue. I got round the issue by running the latest RStudio in WSL2 and it works fine.

I downloaded the latest version of quarto from GitHub, which was supposed to fix the windows bug, but no success. I'm going to try Macos instead. I hope they fix it though since my work laptop is Windows.

Were you able to get it to publish via macOS? I am running into this same issue right now too.

Hi! @nzcoder

I have a problem with "quarto document" as well in windows using Rstudio (the latest stable).

I found one solution that worked for me.

Before I reinstalled R, Rstudio, Rtools, Quarto, and Python, the final solution was the below.

I copied the findstr.exe file from C:\Windows\System32 to C:\Program Files\RStudio\bin.

This solved not only the "create new project" in Rstudio but also the "render .qmd" and other quarto document problems as well.

I hope it works for you as well.