quarto website `qmd`s not rendering

I have a quarto website. All was good, but now I cannot render any document in the Rproj. The message I get is pasted below. I am able to render other quarto documents on my machine. If I open a .qmd the the Rproj that is saved somewhere else, that will render as well.

quarto check looks like everything gets the OK.

Everything was working fine prior to this issue, so I am not sure if I did something, or accidentally moved a file I wasn't supposed to. My git WIP doesn't give me any good clues.

I am needing to post stuff to the website for my students, so I would like to fix ASAP.

Error in if (n == 1) word else paste(word, "s", sep = "") : the condition has length > 1 Calls: source ... sprintf -> <Anonymous> -> nplural -> paste -> plural Execution halted Error in if (n == 1) word else paste(word, "s", sep = "") : the condition has length > 1 Calls: source ... sprintf -> <Anonymous> -> nplural -> paste -> plural
Execution halted
Unable to locate an installed version of R. Install R from https://cloud.r-project.org/

Here are the results of quarto check

[>] Checking versions of quarto binary dependencies...
Pandoc version 3.1.1: OK
Dart Sass version 1.55.0: OK
[>] Checking versions of quarto dependencies......OK
[>] Checking Quarto installation......OK
Version: 1.3.450
Path: C:\Users\jnese\AppData\Local\Programs\Quarto\bin
CodePage: 1252

[>] Checking basic markdown render....OK

[>] Checking Python 3 installation....OK
Version: 3.8.5 (Conda)
Path: C:/Users/jnese/Anaconda3/python.exe
Jupyter: 4.6.3
Kernels: python3

() Checking Jupyter engine render....Traceback (most recent call last):
File "C:\Users\jnese\AppData\Local\Programs\Quarto\share\jupyter\jupyter.py", line
21, in
from notebook import notebook_execute, RestartKernel
File "C:\Users\jnese\AppData\Local\Programs\Quarto\share\jupyter\notebook.py", line 18, in
from nbclient import NotebookClient
File "C:\Users\jnese\Anaconda3\lib\site-packages\nbclient_init_.py", line 3, in

from .client import NotebookClient, execute # noqa: F401
File "C:\Users\jnese\Anaconda3\lib\site-packages\nbclient\client.py", line 21, in
from jupyter_client import KernelManager
File "C:\Users\jnese\Anaconda3\lib\site-packages\jupyter_client_init_.py", line
4, in
from .connect import *
File "C:\Users\jnese\Anaconda3\lib\site-packages\jupyter_client\connect.py", line 21, in
import zmq
File "C:\Users\jnese\Anaconda3\lib\site-packages\zmq_init_.py", line 50, in
from zmq import backend
File "C:\Users\jnese\Anaconda3\lib\site-packages\zmq\backend_init_.py", line 40, in
File "C:\Users\jnese\Anaconda3\lib\site-packages\zmq\utils\sixcerpt.py", line 34, in reraise
raise value
File "C:\Users\jnese\Anaconda3\lib\site-packages\zmq\backend_init_.py", line 27, in
ns = select_backend(first)
File "C:\Users\jnese\Anaconda3\lib\site-packages\zmq\backend\select.py", line 28, in select_backend
mod = import(name, fromlist=public_api)
File "C:\Users\jnese\Anaconda3\lib\site-packages\zmq\backend\cython_init
.py", line 6, in
from . import (constants, error, message, context,
ImportError: DLL load failed while importing error: The specified module could not be found.
[>] Checking Jupyter engine render....OK

One more note/example:

I get the message when I try to render my .index.qmd file, but when I run each chunk, they all run without error.

I think I worked it out. It had to do with an error in a particular script, I believe.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.