r 3.5 Windows - devtools ‘rlang’ does not have a namespace

#1

Having issues post install of devtools when loading as follows:

library(devtools)
Error: package or namespace load failed for ‘devtools’:
package ‘rlang’ does not have a namespace

I am an R newbie, any help appreciated.

0 Likes

#2

Welcome, @mcm220. Looks like you need to install the rlang package. Try running:

install.packages("rlang")

After you've installed rlang, you should be able to load and use devtools.

0 Likes

#3

Many thanks for the help. In the end I had to re-install devtools and use the following code to see the enclosed packages:

> library(devtools)
> library(pkgbuild)

Thanks again for the help, much appreciated

0 Likes

#4

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

1 Like

#5

@andresrcs Sure no problem on the solution. For my issue regarding errors encountered using devtools in R 3.5 , by loading pkgbuild I was able to move forward. The error and simple resolution is below:
'''

find_rtools()
Error in find_rtools() : could not find function "find_rtools"
library(pkgbuild)
Attaching package: ‘pkgbuild’
The following object is masked from ‘package:devtools’:

build

find_rtools()
[1] TRUE

''
Many thanks.

0 Likes

closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.

0 Likes