R 4.2.0 installing bkmr package fail in Mac


I just installed the new version R 4.2.0 and tried to install bkmr package in MacOS Monterey 12.0.1 (intel i5).
But when I ran library(bkmr), it showed:

Error: package or namespace load failed for ‘bkmr’ in dyn.load(file, DLLpath = DLLpath, ...):
unable to load shared object '/Library/Frameworks/R.framework/Versions/4.2/Resources/library/gmm/libs/gmm.so':
dlopen(/Library/Frameworks/R.framework/Versions/4.2/Resources/library/gmm/libs/gmm.so, 0x0006): Library not loaded: /usr/local/gfortran/lib/libgomp.1.dylib
Referenced from: /Library/Frameworks/R.framework/Versions/4.2/Resources/library/gmm/libs/gmm.so
Reason: tried: '/usr/local/gfortran/lib/libgomp.1.dylib' (no such file), '/Library/Frameworks/R.framework/Resources/lib/libgomp.1.dylib' (no such file), '/Users/nl/lib/libgomp.1.dylib' (no such file), '/usr/local/lib/libgomp.1.dylib' (no such file), '/usr/lib/libgomp.1.dylib' (no such file), '/lib/libgomp.1.dylib' (no such file), '/Library/Java/JavaVirtualMachines/jdk1.8.0_241.jdk/Contents/Home/jre/lib/server/libgomp.1.dylib' (no such file), '/var/folders/gp/lc70br596bd7qsdb1nn54k3m0000gn/T/rstudio-fallback-library-path-w8cTyO

I've tried to removed the package and reinstalled R, RStudio and the package. I also installed XQuartz-8.2.1.
But the issue is still there.

If anyone knows how to solve it, please let me know.
Thank you very much.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.