R aborted or encountered a fatal error

Halo, I am encountering a classic problem with my R both Studio and GUI.
I am using version 3.6.3 on my Macbook pro.

I have been using R to run analyses and sometimes had an error such R session aborted, usually just by restarting the project the problem was solved.

Just today, I have been struggling to get R program worked, but it keeps showing errors.
when I open the project it tells: "R encountered a fatal error, the session was terminated"
I tried to start a new project, but when I install packages such as "adegenet" and "darT", my R studio always gets the "R Session aborted".

I did a try by reinstalling R installing R-GUI and R-Studio and had my Java updated following the success story in this previous post :R session aborted all the time
But did not work.

I tried to run the project on R-GUI instead of R studio, the problem still occurs.

Upgrading my R to the latest is not an option as my colleagues use the same version as I have and we like to keep it that way for some reason.

I'd be thankful to anybody that could help me with this issue. Thank you.

I solved the problem by these followings steps:

  1. removing package ("dplyr") and reinstall using: install.packages("dplyr",dependencies=TRUE)
    Reff: .onLoad failed in loadNamespace() for 'sf', details: · Issue #153 · walkerke/tidycensus · GitHub

Since my R version (3.6.3) wasn't compatible to latest version of adegenet package, I deleted the automatic updated version and downgraded it with the previous version my R version suited with, using command:
2. packageurl <- "https://cran.r-project.org/src/contrib/Archive/adegenet/adegenet_2.1.3.tar.gz".

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.