"R-CMD-check.yaml" fails

A few days ago, I got, 'GitHub action reports, <<'"pdflatex"' not found>> with vignettes. ' Someone suggested I add "tlmgr" to "fda/R-CMD-check.yaml at master · JamesRamsay5/fda · GitHub". Now it doesn't run at all. I don't know yaml and I don't know how to start debugging. Thanks, Spencer Graves

See the example here: actions/setup-tinytex at v2-branch · r-lib/actions · GitHub

Hi, Gabor: Before I created this post, I tried to follow that without success. I added the lines "To install CTAN packages manually" without deleting anything that was there before that seems to work with other packages and without using the "TinyTeX bundled release". Lines 37-55 of 99 in "R-CMD-check.yaml" currently read as follows:

steps:
  - uses: actions/checkout@v2

  - uses: r-lib/actions/setup-r@v2
    with:
      r-version: ${{ matrix.config.r }}
      http-user-agent: ${{ matrix.config.http-user-agent }}
      use-public-rspm: true
      rtools-version: ${{ matrix.donvig.rtools-version }}

  - uses: r-lib/actions/setup-pandoc@v2

  - uses: r-lib/actions/setup-tinytex@v2
  - uses: tlmgr --version 

  - name: Install additional LaTeX packages 
    run: | 
      tlmgr install titlesec
      tlmgr list --only-installed

** What do you suggest I do to debug? It doesn't run, but I don't see an error message. Thanks, Spencer

I suggest you use the example as is, without adding extra lines.

Also, you only need the "Install CTAN packages" part if you actually need extra CTAN packages. If you don't then you only need a single step, with a single line, like in actions/setup-tinytex at v2-branch · r-lib/actions · GitHub :

- uses: r-lib/actions/setup-tinytex@v2

Thanks again for the suggestions. So far, I'm still stymied. I ran "usethis::use_github_action_check_standard()", which overwrote my previous "R-CMD-check.yaml" file with a new one. Sadly, it still gave "pdflatex: command not found" as before. I added

  • uses: r-lib/actions/setup-tinytex@v2

as you suggested with the same result. ??? Thanks again, Spencer Graves

The steps are performed in the order you write them. You need to set up tinytex before you run the package checks.

Btw. this workflow uses an outdated version of the actions, the new version is v2, see the example workflows here: GitHub - r-lib/actions: GitHub Actions for the R community