r-forge issue with DT??

Hi I am struggling with deploying a package to shinyapps.io. continue to get the following error message:

Error parsing manifest: Unknown repository for package source: r-forge
Execution halted

When I deploy the following app:

# Define UI for application that draws a histogram
ui <- fluidPage(
    # Application title
    titlePanel("Old Faithful Geyser Data"),
    # Sidebar with a slider input for number of bins 
                        "Number of bins:",
                        min = 1,
                        max = 50,
                        value = 30)
        # Show a plot of the generated distribution

# Define server logic required to draw a histogram
server <- function(input, output) {
    output$distPlot <- renderPlot({
        # generate bins based on input$bins from ui.R
        x    <- faithful[, 2] 
        bins <- seq(min(x), max(x), length.out = input$bins + 1)
        # draw the histogram with the specified number of bins
        hist(x, breaks = bins, col = 'darkgray', border = 'white')

# Run the application 
shinyApp(ui = ui, server = server)

I can deploy the above if I do not include DT (which I know I don't need, but for another app I do). Any idea why this would cause an issue? Is there something else that I need to do. All my current packages are up to date and I'm on 3.5.1 for R.

1 Like

The error seems to indicate that you have a r-forge package and during deployment it could not be determined from which repos it comes from. Does it mean something to you this r-forge package ?

If you think it comes from DT, have you tried to reinstall DT properly from CRAN ?

To get more informations, can you check the value of getOption("repos") and sessioninfo::session_info() (after you run the app once) ?

For reference, question related to Problem deploying shinyapp into shinyapp.io (unknown repository for package source)



Thanks for the input and idea. It turns out that my colorspace package was the one that was built on rforge. It was a dependency so it was difficult to see the issue. In order to troubleshoot based on your idea I wrote the following code after I loaded in the three or so libraries that I was using:

sessionInfo()-> info

packages_loaded <- info$loadedOnly

packages_loaded %>% 
  map_df(., ~sum(grepl(., pattern = "CRAN"))) %>% 
  gather(package, status) %>% 
  filter(status !=1)

Any non-base packages that appears I reinstalled from cran.

It worked!


rsconnect::appDependencies() will report the packages, versions, and the repository.


If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.