R installation failed

Hello,

I am trying to install rstudio on my Centos 7 machine, starting with an update of the ecosystem by installing epel-repository which is essential for the installation of R, then proceed to the installation of the R language, except that at the level of
of this phase I am blocked, the packages were not well installed and it brings me back this error :
Error: Package: libicu-devel-50.1.2-17.el7.x86_64 (centos7)
Requires: libicu(x86-64) = 50.1.2-17.el7
Installed: libicu-50.2-4.el7_7.x86_64 (@centos76_repository)
libicu(x86-64) = 50.2-4.el7_7
Available: libicu-50.1.2-17.el7.x86_64 (centos7)
libicu(x86-64) = 50.1.2-17.el7
Error: Package: 1:cups-client-1.6.3-35.el7.x86_64 (centos7)
Requires: cups-libs(x86-64) = 1:1.6.3-35.el7
Installed: 1:cups-libs-1.6.3-51.el7.x86_64 (@ums_centos_7_public_os)
cups-libs(x86-64) = 1:1.6.3-51.el7
Available: 1:cups-libs-1.6.3-35.el7.x86_64 (centos7)
cups-libs(x86-64) = 1:1.6.3-35.el7
Error: Package: 1:java-1.8.0-openjdk-devel-1.8.0.201.b09-2.el7_6.x86_64 (centos7-updates)
Requires: java-1.8.0-openjdk(x86-64) = 1:1.8.0.201.b09-2.el7_6
Installed: 1:java-1.8.0-openjdk-1.8.0.292.b10-1.el7_9.x86_64 (@ums_centos_7_public_updates)
java-1.8.0-openjdk(x86-64) = 1:1.8.0.292.b10-1.el7_9
Available: 1:java-1.8.0-openjdk-1.8.0.181-7.b13.el7.x86_64 (centos7)
java-1.8.0-openjdk(x86-64) = 1:1.8.0.181-7.b13.el7
Available: 1:java-1.8.0-openjdk-1.8.0.201.b09-2.el7_6.x86_64 (centos7-updates)
java-1.8.0-openjdk(x86-64) = 1:1.8.0.201.b09-2.el7_6
Available: 1:java-1.8.0-openjdk-1.8.0.191.b12-1.el7_6.i686 (centos7-updates)
~java-1.8.0-openjdk(x86-32) = 1:1.8.0.191.b12-1.el7_6
Error: Package: 1:cups-1.6.3-35.el7.x86_64 (centos7)
Requires: cups-libs(x86-64) = 1:1.6.3-35.el7
Installed: 1:cups-libs-1.6.3-51.el7.x86_64 (@ums_centos_7_public_os)
cups-libs(x86-64) = 1:1.6.3-51.el7
Available: 1:cups-libs-1.6.3-35.el7.x86_64 (centos7)
cups-libs(x86-64) = 1:1.6.3-35.el7
Error: Package: 2:libpng-devel-1.5.13-7.el7_2.x86_64 (centos7)
Requires: libpng(x86-64) = 2:1.5.13-7.el7_2
Installed: 2:libpng-1.5.13-8.el7.x86_64 (@ums_centos_7_public_os)
libpng(x86-64) = 2:1.5.13-8.el7
Available: 2:libpng-1.5.13-7.el7_2.x86_64 (centos7)
libpng(x86-64) = 2:1.5.13-7.el7_2
Error: Package: glibc-2.17-260.el7_6.3.i686 (centos7-updates)
Requires: glibc-common = 2.17-260.el7_6.3
Installed: glibc-common-2.17-324.el7_9.x86_64 (@ums_centos_7_public_updates)
glibc-common = 2.17-324.el7_9
Available: glibc-common-2.17-260.el7.x86_64 (centos7)
glibc-common = 2.17-260.el7
Available: glibc-common-2.17-260.el7_6.3.x86_64 (centos7-updates)
glibc-common = 2.17-260.el7_6.3
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Has anyone had the same problem?
Thank you in advance for your feedback

It looks like you have conflicting yum repositories configured/activated. Some seem to point to CentOS 7.6, some others to CentOS 7, some others to ums_centos_7....

I would suggest to follow step 3 from this link, especially the modifications to CentOS-Base.repo in /etc/yum.repos.d

Once done, I am almost certain your installation will succeed.