r-lib/actions/setup-r results in 403 on GHA

On GitHub Actios (GHA), I tried r-lib/actions/setup-r@v1 and
r-lib/actions/setup-r@master and on R 4.0.4 (R release) it results in:

  • Is this behavior expected at this moment? (Yesterday it worked as expected)
  • What is the cause of this 403 issue: is it a bug in the action I use or is it due to some changes in the server with R devel?

Just reported this in another topic. To me it only happened on ubuntu. Probably it is an error on the setup-r action

It might be related to the fact that R 4.0.4 was released yesterday:

image

Maybe but on Windows and iOS it didn't fail

As reported in the topic created by @llrs, @cderv pointed me to https://github.com/rstudio/r-builds/issues/89

1 Like

The R binary for Linux installation is not available yet in r-builds. The action uses that, so the action is failing.

For windows and MacOS, CRAN offers a binary so this one is used by the action and this is why it is not failing.

3 Likes

This is now fixed and the build should be available.