R markdown 1.8.2 is not generating tabbed sections

rmarkdown

#1

I am trying to update an R markdown document that uses the {.tabset} option, but I’m not getting tabs, as expected. This same file generated fine the last time the report was generated (about six weeks ago). Both rmarkdown and pandoc have been updated since then, although I do not remember the exact versions that were used previously. Running under macOS Sierra 10.12.6, using R version 3.4.2, rmarkdown 1.8.2 and pandoc 2.0.2, the following does not create tabs:

---
title: "Missing Tabs"
output: html_document
---

# Tabset here {.tabset}

## tab1
```{r}
summary(cars)
```

## tab 2
```{r}
summary(pressure)
```

Other options (e.g., table of contents, appearance, styling) seem to be functioning correctly, but I can’t figure out what’s changed. Thanks!


#2

There is no need to upgrade to Pandoc 2.0 unless there is some specific new features in Pandoc 2.0 that you really want: https://yihui.name/en/2017/11/pandoc-2/ That said, this is a bug and I just fixed it. Please test the development version of rmarkdown: https://github.com/rstudio/rmarkdown Thanks!


#3

I really appreciate your prompt response! Not surprisingly, the fix works exactly as advertised. Thanks for the link to your blog post as well. I hadn’t realized Pandoc is bundled with RStudio, and as you suspected, the upgrade to 2.0 was the result of a recent brew upgrade command.


#4

Thanks! I was trying to design a report yesterday and could not figure out why that wouldn’t work. Glad to hear it was swiftly fixed.


#5

Thank you, I was having this issue as well. Any idea when this fix will be released outside of the development version?


#6

Yes, in about two weeks.