R package translations not available for this version of R [4.1.0]

I asked this question about a year ago and never got a response. In the process of updating my packages in my R version 4.1.0 (2021-05-18) on my Windows 10 and Ubuntu 20.04 LTS desktops, I found a package on my Windows 10 system, "translations," that was lacking on my Ubuntu desktop, so I tried to install the package on my Ubuntu desktop. I got the response:

Installing package into ‘C:/Users/hunsickerl/Documents/Home/R/win-library/4.1’
(as ‘lib’ is unspecified)
Warning in install.packages :
package ‘translations’ is not available for this version of R

So I tried to mount "translations" on my Windows desktop, and got the following response:

Error in library(translations) :
package ‘translations’ does not have a namespace and should be re-installed

Indeed, there was no 'translations' folder in my personal libPath, but there was a 'translations' folder in the system Program Files/R/R 4.1.0/library folder, and it had all the subfolders that would be expected of a legitimate R package. It was evidently installed as a system package by the R installer.

I can find no information on the web about an R package translations. Is this package needed for R 4.1.0? Has it simply been copied from prior R versions in the process of updates? Does anyone have an explanation of the apparent dropping of the 'translations' package in current R versions?

Thanks to anyone that can explain this anomaly, and let me know whether the translations package is needed for my Windows version?

Larry Hunsicker

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.