R studio doesn't link with R (exiting with code 10)

I work with R all the time but since I had to install the newest version of R Studio and R, it doesn't make the connection with R anymore. I get the following error information:

R Session Startup Failure Report

Process Output
The R session exited with code 10.

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 1.4.1717
  • OS Version: Windows 10
  • R Version: 4.1.0

Have you tried resetting RStudio's state?

Hi, thank you for you respons.

In the reset article, they suggest: "You can open an Explorer window into the RStudio-Desktop directory by typing the following command into Start -> Run:"

Problem is that RStudio doesn't give me the chance to type code anymore.
All the bottons above are also frozen (File, Edit, Code, View,...). Only thing I can do is deinstall RStudio.

You are not supposed to type that command in RStudio, the article is talking about the Windows File Explorer, simply look for the file and delete it or rename it, just like you would do with any other file.

1 Like

The problem is solved.

We recently changed to Microsoft Intune and it was a Microsoft technical issue. Microsoft forces R Studio to be installed as administrator but R have to be installed as administrator. Here lays the problem.

  1. We de-installed R and R Studio

  2. We installed R as administrator

  3. We installed R Studio as administrator (default)

=> Works fine now.

Thank you for your help.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.