R Studio hangs after updating R to 3.4.4. Works well with admin login but not with other users on Windows. Installed previous versions of RStudio & R. None worked


#1
[1] "1.1.442"

$R
[1] "C:\\Users\\162813\\DOCUME~1\\R\\R-34~1.4\\bin\\i386\\R.exe"

$pdflatex
[1] ""

$bibtex
[1] ""

$gcc
[1] ""

$git
[1] ""

$svn
[1] ""

R version 3.4.4 (2018-03-15)
Platform: i386-w64-mingw32/i386 (32-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252 
[2] LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.4.4 tools_3.4.4   

SysInfo:
       sysname        release        version       nodename        machine 
     "Windows"     ">= 8 x64"   "build 9200" "JITSNBC74779"          "x86" 
         login           user effective_user 
      "162813"       "162813"       "162813" 

R Version:
               _                           
platform       i386-w64-mingw32            
arch           i386                        
os             mingw32                     
system         i386, mingw32               
status                                     
major          3                           
minor          4.4                         
year           2018                        
month          03                          
day            15                          
svn rev        74408                       
language       R                           
version.string R version 3.4.4 (2018-03-15)
nickname       Someone to Lean On          
$ALLUSERSPROFILE
[1] "C:\\ProgramData"

$APPDATA
[1] "C:\\Users\\162813\\AppData\\Roaming"

$asl.log
[1] "Destination=file"

$CLICOLOR_FORCE
[1] "1"

$CommonProgramFiles
[1] "C:\\Program Files (x86)\\Common Files"

$`CommonProgramFiles(x86)`
[1] "C:\\Program Files (x86)\\Common Files"

$CommonProgramW6432
[1] "C:\\Program Files\\Common Files"

$COMPUTERNAME
[1] "JITSNBC74779"

$ComSpec
[1] "C:\\Windows\\system32\\cmd.exe"

$FP_NO_HOST_CHECK
[1] "NO"

$GFORTRAN_STDERR_UNIT
[1] "-1"

$GFORTRAN_STDOUT_UNIT
[1] "-1"

$HOME
[1] "C:/Users/162813/Documents"

$HOMEDRIVE
[1] "C:"

$HOMEPATH
[1] "\\Users\\162813"

$LOCALAPPDATA
[1] "C:\\Users\\162813\\AppData\\Local"

$LOGONSERVER
[1] "\\\\JSITIS0325"

$LSHOST
[1] "160.0.50.111"

$MSMPI_BIN
[1] "C:\\Program Files\\Microsoft MPI\\Bin\\"

$NUMBER_OF_PROCESSORS
[1] "4"

$OS
[1] "Windows_NT"

$PATH
[1] "C:\\Users\\162813\\Documents\\R\\R-3.4.4\\bin\\i386;C:\\Program Files\\Common Files\\Microsoft Shared\\Microsoft Online Services;C:\\Program Files (x86)\\Common Files\\Microsoft Shared\\Microsoft Online Services;C:\\Program Files\\Microsoft MPI\\Bin\\;G:\\app\\WORKSPACE\\product\\11.2.0\\client_1\\bin;G:\\app\\162813\\product\\11.2.0\\client_1\\bin;C:\\Program Files (x86)\\Intel\\iCLS Client\\;C:\\Program Files\\Intel\\iCLS Client\\;C:\\Windows\\system32;C:\\Windows;C:\\Windows\\System32\\Wbem;C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\;C:\\Program Files\\Intel\\Intel(R) Management Engine Components\\DAL;C:\\Program Files (x86)\\Intel\\Intel(R) Management Engine Components\\DAL;C:\\Program Files\\Intel\\Intel(R) Management Engine Components\\IPT;C:\\Program Files (x86)\\Intel\\Intel(R) Management Engine Components\\IPT;C:\\Program Files\\MATLAB\\MATLAB Compiler Runtime\\v715\\runtime\\win64;C:\\ProgramData\\Miniconda3;C:\\ProgramData\\Miniconda3\\Scripts;C:\\ProgramData\\Miniconda3\\Library\\bin;C:\\Users\\162813\\AppData\\Local\\Continuum\\Anaconda3;C:\\Users\\162813\\AppData\\Local\\Continuum\\Anaconda3\\Scripts;C:\\Users\\162813\\AppData\\Local\\Continuum\\Anaconda3\\Library\\bin"

$PATHEXT
[1] ".COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC"

$PROCESSOR_ARCHITECTURE
[1] "x86"

$PROCESSOR_ARCHITEW6432
[1] "AMD64"

$PROCESSOR_IDENTIFIER
[1] "Intel64 Family 6 Model 61 Stepping 4, GenuineIntel"

$PROCESSOR_LEVEL
[1] "6"

$PROCESSOR_REVISION
[1] "3d04"

$ProgramData
[1] "C:\\ProgramData"

$ProgramFiles
[1] "C:\\Program Files (x86)"

$`ProgramFiles(x86)`
[1] "C:\\Program Files (x86)"

$ProgramW6432
[1] "C:\\Program Files"

$PROMPT
[1] "$P$G"

$PSModulePath
[1] "C:\\Windows\\system32\\WindowsPowerShell\\v1.0\\Modules\\"

$PTSMINSTALLPATH_X86
[1] "C:\\Program Files (x86)\\Hewlett-Packard\\HP ProtectTools Security Manager\\"

$PUBLIC
[1] "C:\\Users\\Public"

$R_ARCH
[1] "/i386"

$R_COMPILED_BY
[1] "gcc 4.9.3"

$R_DOC_DIR
[1] "C:/Users/162813/DOCUME~1/R/R-34~1.4/doc"

$R_HOME
[1] "C:/Users/162813/DOCUME~1/R/R-34~1.4"

$R_LIBS_USER
[1] "C:/Users/162813/Documents/R/win-library/3.4"

$R_USER
[1] "C:/Users/162813/Documents"

$RMARKDOWN_MATHJAX_PATH
[1] "C:/Users/162813/Documents/RStudio/resources/mathjax-26"

$RS_LOCAL_PEER
[1] "\\\\.\\pipe\\18041-rsession"

$RS_RPOSTBACK_PATH
[1] "C:/Users/162813/Documents/RStudio/bin/rpostback"

$RS_SHARED_SECRET
[1] "63341846741"

$RSTUDIO
[1] "1"

$RSTUDIO_CONSOLE_COLOR
[1] "256"

$RSTUDIO_CONSOLE_WIDTH
[1] "80"

$RSTUDIO_MSYS_SSH
[1] "C:/Users/162813/Documents/RStudio/bin/msys-ssh-1000-18"

$RSTUDIO_PANDOC
[1] "C:/Users/162813/Documents/RStudio/bin/pandoc"

$RSTUDIO_SESSION_PORT
[1] "18041"

$RSTUDIO_USER_IDENTITY
[1] "162813"

$RSTUDIO_WINUTILS
[1] "C:/Users/162813/Documents/RStudio/bin/winutils"

$SESSIONNAME
[1] "Console"

$SystemDrive
[1] "C:"

$SystemRoot
[1] "C:\\Windows"

$TEMP
[1] "C:\\Users\\162813\\AppData\\Local\\Temp"

$TERM
[1] "xterm-256color"

$TMP
[1] "C:\\Users\\162813\\AppData\\Local\\Temp"

$UATDATA
[1] "C:\\Windows\\CCM\\UATData\\D9F8C395-CAB8-491d-B8AC-179A1FE1BE77"

$USERDNSDOMAIN
[1] "CORP.TATASTEEL.COM"

$USERDOMAIN
[1] "TATASTEEL"

$USERDOMAIN_ROAMINGPROFILE
[1] "TATASTEEL"

$USERNAME
[1] "162813"

$USERPROFILE
[1] "C:\\Users\\162813"

$windir
[1] "C:\\Windows"

 [1] ".GlobalEnv"        "tools:rstudio"     "package:stats"    
 [4] "package:graphics"  "package:grDevices" "package:utils"    
 [7] "package:datasets"  "package:methods"   "Autoloads"        
[10] "package:base"     
Log file: rdesktop.log
--------------------------------------------------

(Empty)

Log file: rsession-162813.log
--------------------------------------------------

(Empty)


#2

Do your non admin users have access to this folder where R is installed? It looks like it is in a user folder. Try making sure that R and RStudio are installed outside the user folders.


#3

Installed R and Rstudio in non-admin folder. The issue still persists.


#4

If you close RStudio when it hangs, then reopen it will it load correctly then? Sometimes that happens to me. For some reason our security software grabs ahold of programs during loading.

Only other thing I can think of is to make sure your path to R is correct in your settings, and any security software is not blocking the folder where R is. Since the folder changes by default with a new r version maybe the old folder was whitelisted but the new is not.


#5

No, it doesn't work. I'm sharing the latest diagnostics report. Earlier, I could work in RStudio with admin login. Now even that's not working. Have installed previous versions of R and RStudio, didn't work.

[1] "1.0.153"

$R
[1] "C:\\Users\\162813\\DOCUME~1\\R\\R-34~1.4\\bin\\x64\\R.exe"

$pdflatex
[1] ""

$bibtex
[1] ""

$gcc
[1] ""

$git
[1] ""

$svn
[1] ""

R version 3.4.4 (2018-03-15)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252 
[2] LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.4.4 tools_3.4.4   

SysInfo:
       sysname        release        version       nodename        machine 
     "Windows"     ">= 8 x64"   "build 9200" "JITSNBC74779"       "x86-64" 
         login           user effective_user 
      "162813"       "162813"       "162813" 

R Version:
               _                           
platform       x86_64-w64-mingw32          
arch           x86_64                      
os             mingw32                     
system         x86_64, mingw32             
status                                     
major          3                           
minor          4.4                         
year           2018                        
month          03                          
day            15                          
svn rev        74408                       
language       R                           
version.string R version 3.4.4 (2018-03-15)
nickname       Someone to Lean On          
$ALLUSERSPROFILE
[1] "C:\\ProgramData"

$APPDATA
[1] "C:\\Users\\162813\\AppData\\Roaming"

$asl.log
[1] "Destination=file"

$CommonProgramFiles
[1] "C:\\Program Files\\Common Files"

$`CommonProgramFiles(x86)`
[1] "C:\\Program Files (x86)\\Common Files"

$CommonProgramW6432
[1] "C:\\Program Files\\Common Files"

$COMPUTERNAME
[1] "JITSNBC74779"

$ComSpec
[1] "C:\\Windows\\system32\\cmd.exe"

$FP_NO_HOST_CHECK
[1] "NO"

$GFORTRAN_STDERR_UNIT
[1] "-1"

$GFORTRAN_STDOUT_UNIT
[1] "-1"

$HOME
[1] "C:/Users/162813/Documents"

$HOMEDRIVE
[1] "C:"

$HOMEPATH
[1] "\\Users\\162813"

$LOCALAPPDATA
[1] "C:\\Users\\162813\\AppData\\Local"

$LOGONSERVER
[1] "\\\\ADCTSLJSR02"

$LSHOST
[1] "160.0.50.111"

$MSMPI_BIN
[1] "C:\\Program Files\\Microsoft MPI\\Bin\\"

$NUMBER_OF_PROCESSORS
[1] "4"

$OS
[1] "Windows_NT"

$PATH
[1] "C:\\Users\\162813\\Documents\\R\\R-3.4.4\\bin\\x64;C:\\Program Files\\Common Files\\Microsoft Shared\\Microsoft Online Services;C:\\Program Files (x86)\\Common Files\\Microsoft Shared\\Microsoft Online Services;C:\\Program Files\\Microsoft MPI\\Bin\\;G:\\app\\WORKSPACE\\product\\11.2.0\\client_1\\bin;G:\\app\\162813\\product\\11.2.0\\client_1\\bin;C:\\Program Files (x86)\\Intel\\iCLS Client\\;C:\\Program Files\\Intel\\iCLS Client\\;C:\\Windows\\system32;C:\\Windows;C:\\Windows\\System32\\Wbem;C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\;C:\\Program Files\\Intel\\Intel(R) Management Engine Components\\DAL;C:\\Program Files (x86)\\Intel\\Intel(R) Management Engine Components\\DAL;C:\\Program Files\\Intel\\Intel(R) Management Engine Components\\IPT;C:\\Program Files (x86)\\Intel\\Intel(R) Management Engine Components\\IPT;C:\\Program Files\\MATLAB\\MATLAB Compiler Runtime\\v715\\runtime\\win64;C:\\ProgramData\\Miniconda3;C:\\ProgramData\\Miniconda3\\Scripts;C:\\ProgramData\\Miniconda3\\Library\\bin;C:\\Users\\162813\\AppData\\Local\\Continuum\\Anaconda3;C:\\Users\\162813\\AppData\\Local\\Continuum\\Anaconda3\\Scripts;C:\\Users\\162813\\AppData\\Local\\Continuum\\Anaconda3\\Library\\bin"

$PATHEXT
[1] ".COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC"

$PROCESSOR_ARCHITECTURE
[1] "AMD64"

$PROCESSOR_IDENTIFIER
[1] "Intel64 Family 6 Model 61 Stepping 4, GenuineIntel"

$PROCESSOR_LEVEL
[1] "6"

$PROCESSOR_REVISION
[1] "3d04"

$ProgramData
[1] "C:\\ProgramData"

$ProgramFiles
[1] "C:\\Program Files"

$`ProgramFiles(x86)`
[1] "C:\\Program Files (x86)"

$ProgramW6432
[1] "C:\\Program Files"

$PROMPT
[1] "$P$G"

$PSModulePath
[1] "C:\\Windows\\system32\\WindowsPowerShell\\v1.0\\Modules\\"

$PTSMINSTALLPATH_X86
[1] "C:\\Program Files (x86)\\Hewlett-Packard\\HP ProtectTools Security Manager\\"

$PUBLIC
[1] "C:\\Users\\Public"

$R_ARCH
[1] "/x64"

$R_COMPILED_BY
[1] "gcc 4.9.3"

$R_DOC_DIR
[1] "C:/Users/162813/DOCUME~1/R/R-34~1.4/doc"

$R_HOME
[1] "C:/Users/162813/DOCUME~1/R/R-34~1.4"

$R_LIBS_USER
[1] "C:/Users/162813/Documents/R/win-library/3.4"

$R_USER
[1] "C:/Users/162813/Documents"

$RMARKDOWN_MATHJAX_PATH
[1] "C:/Program Files/RStudio/resources/mathjax-26"

$RS_LOCAL_PEER
[1] "\\\\.\\pipe\\19856-rsession"

$RS_RPOSTBACK_PATH
[1] "C:/Program Files/RStudio/bin/rpostback"

$RS_SHARED_SECRET
[1] "63341846741"

$RSTUDIO
[1] "1"

$RSTUDIO_MSYS_SSH
[1] "C:/Program Files/RStudio/bin/msys-ssh-1000-18"

$RSTUDIO_PANDOC
[1] "C:/Program Files/RStudio/bin/pandoc"

$RSTUDIO_SESSION_PORT
[1] "19856"

$RSTUDIO_USER_IDENTITY
[1] "162813"

$RSTUDIO_WINUTILS
[1] "C:/Program Files/RStudio/bin/winutils"

$SESSIONNAME
[1] "Console"

$SystemDrive
[1] "C:"

$SystemRoot
[1] "C:\\Windows"

$TEMP
[1] "C:\\Users\\162813\\AppData\\Local\\Temp"

$TMP
[1] "C:\\Users\\162813\\AppData\\Local\\Temp"

$UATDATA
[1] "C:\\Windows\\CCM\\UATData\\D9F8C395-CAB8-491d-B8AC-179A1FE1BE77"

$USERDNSDOMAIN
[1] "CORP.TATASTEEL.COM"

$USERDOMAIN
[1] "TATASTEEL"

$USERDOMAIN_ROAMINGPROFILE
[1] "TATASTEEL"

$USERNAME
[1] "162813"

$USERPROFILE
[1] "C:\\Users\\162813"

$windir
[1] "C:\\Windows"

 [1] ".GlobalEnv"        "tools:rstudio"     "package:stats"    
 [4] "package:graphics"  "package:grDevices" "package:utils"    
 [7] "package:datasets"  "package:methods"   "Autoloads"        
[10] "package:base"     
Log file: rdesktop.log
--------------------------------------------------

(Empty)

Log file: rsession-162813.log
--------------------------------------------------

(Empty)