R Studio is damage and can't be opened after dragging to Application folder

I have just downloaded the latest Rstudio (1.4.1717) and I'm having trouble opening it. I can open it directly from the .dmg file, but if I drag to the Application folder I says Rstudio is damaged. I've downloaded the .dmg file multiple times, restarted the computer, used different wifi connections, it still does not work. I've recently updated R, conda, and installed jupyter and some other packages. I suspect it might be something PATH related.

If I try to open it from terminal with open -na Rstudio.app, it returns 'Unable to find applicatio named 'RStudio.app'.

It also did not help reseting Rstudio following the instructions here: Resetting RStudio Desktop's State – RStudio Support

When I run a diagnostic report, everything seems fine:

(base) MacBook-Pro-de-USER:~ USER$ /Applications/RStudio.app/Conten
ts/MacOS/RStudio --run-diagnostics

Using R script: /Library/Frameworks/R.framework/Versions/4.1/Resources/bin/R

Attempting to launch R session...
R_HOME=/Library/Frameworks/R.framework/Resources
R_DOC_DIR=/Library/Frameworks/R.framework/Resources/doc
R_INCLUDE_DIR=/Library/Frameworks/R.framework/Resources/include
R_SHARE_DIR=/Library/Frameworks/R.framework/Resources/share
DYLD_FALLBACK_LIBRARY_PATH=/Library/Frameworks/R.framework/Resources/lib:/Users/USER/lib:/usr/local/lib:/usr/lib:::/lib:/Library/Java/JavaVirtualMachines/jdk1.8.0_241.jdk/Contents/Home/jre/lib/server
PATH=/Library/Frameworks/Python.framework/Versions/3.9/bin:/usr/local/opt/icu4c/bin:/Users/USER/miniconda3/bin:/Users/USER/miniconda3/condabin:/Library/Frameworks/Python.framework/Versions/3.6/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin
HOME=/Users/USER

R session launched, attempting to connect on port 38588...

Connected to R session, attempting to initialize...

Successfully initialized R session.

Diagnostics report written to: /Users/USER/rstudio-diagnostics/diagnostics-report.txt
Please audit the report and remove any sensitive information before submitting.

When opening Rstudio from within the .dmg file, typing sessioninfor() returns:

sessionInfo()
R version 4.1.0 (2021-05-18)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS High Sierra 10.13.6

Matrix products: default
BLAS: /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/4.1/Resources/lib/libRlapack.dylib

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] compiler_4.1.0 pbdZMQ_0.3-5 tools_4.1.0

I'm running:
mac os High Sierra 10.13.6
R 4.1.0

I appreciate any guidance to solve this.

I'm on High Sierra 10.13.6, too, and just had the same problem. I managed to start RStudio from the command line using

/Applications/RStudio.app/Contents/MacOS/RStudio

Terminal throws two error messages, but I'm not sure if they are related to the problem

GVA error: Not detecting IGPU in IORegistry!
GVA error: Not detecting valid offline codec!

However, even after the first launch, the application will still not start from the Dock next time.

The problem seems to be related to MacOS's app verification not playing nicely with this version of RStudio. As a result, the app retains its "quarantine" attribute and cannot bypass the verification. You can remove that attribute (proceed at your own risk) by using

xattr -d com.apple.quarantine /Applications/RStudio.app/
3 Likes

Thanks @jflintwinch, that did it for me.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.