R Studio Server Error while installing dplyr package

Hi everyone!
I am trying to update the dplyr package up to 0.8.0 version on my R studio server but I am not able to do it.
I need it updated for other packages that otherwise I will not be able to update.
I tried to install dplyr package either with "dependencies = TRUE" and "dependencies = FALSE" (and trying to install dependencies manually ), but nor of them worked.

Do you have any suggestion?
Hope someone could help me!

Here the message:

> install.packages("dplyr")
Installing package into ‘/home/draghib/R/x86_64-pc-linux-gnu-library/3.5’
(as ‘lib’ is unspecified)
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  702k  100  702k    0     0   381k      0  0:00:01  0:00:01 --:--:--  381k
* installing *source* package ‘dplyr’ ...
** package ‘dplyr’ successfully unpacked and MD5 sums checked
** libs
[ ... ] 
installing to /home/draghib/R/x86_64-pc-linux-gnu-library/3.5/dplyr/libs
** R
** data
*** moving datasets to lazyload DB
** inst
** byte-compile and prepare package for lazy loading
Warning: As of rlang 0.4.0, dplyr must be at least version 0.8.0.
* dplyr 0.7.8 is too old for rlang 0.4.10.
* Please update dplyr with `install.packages("dplyr")` and restart R.
** help
*** installing help indices
*** copying figures
** building package indices
** installing vignettes
** testing if installed package can be loaded
Warning: As of rlang 0.4.0, dplyr must be at least version 0.8.0.
* dplyr 0.7.8 is too old for rlang 0.4.10.
* Please update dplyr with `install.packages("dplyr")` and restart R.
* DONE (dplyr)

Hi,

I'm not 100% sure what's going on, but it seens various package versions are in conflict with each other. If you like to have the latest versions, I suggest you update the whole Tidyverse instead of just dplyr.

install.packages("tidyverse")

This way all dependencies should be updated correctly I think.

Hope this helps,
PJ

in your position I would probably try to revert to rlang version 0.3.1 as that was the version that dplyr 0.8 required as a minimum on its release in February of 2019. I used MRAN's 'CRAN time machine' to determine that.

using renv package to install a particular version would be straightforward. i.e.
renv::install("rlang@0.3.1")

However, I'm guessing it would be better for you to upgrade your r version and then reinstall the most recent versions of everything,

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.

Hi Pieter,
I've already tried to update the whole Tidyverse but it didn't work.
I think is an issue related to the R version installed on R studio server.
Thank you anyway