R Studio (Version 1.2.1070) Closes when Windows is Locked (Windows + L)


#1

I truly have no idea whats going on. I start a fresh session of R studio and when I lock my Windows 10 computer (Windows + L), and log back in, Rstudio is automatically closed. This has lead me to lose alot of work simply because I wait fro scripts to run and come back to find that Rstudio has been closed.I have been searching forums for hours but can't seem to track down the issue. Anyone experiencing similar issues? Help?


#2

I wasn't able to reproduce this. Can you provide any other information?

  • Does RStudio always close in this way when you lock the desktop? Or does it seem to depend on which R project you have opened, or what kind of R code you've been executing, or anything similar?

  • Is RStudio installed on your local filesystem? Are you using RStudio with e.g. mounted or network drives?

A diagnostics report may also be helpful.


#3

Sorry for the late reply. I really appreciate the help

  • I ran multiple tests and it almost always happens with I put the computer to sleep. As soon as the computer comes out of sleep, Rstudio is closed (regardless whether code is running or not)

  • Rstudio is installed locally.

Below is the diagnostic report

[1] "1.2.1070"

$R
[1] "C:\\PROGRA~1\\R\\R-35~1.1\\bin\\x64\\R.exe"

$pdflatex
[1] ""

$bibtex
[1] ""

$gcc
[1] ""

$git
[1] "C:\\PROGRA~1\\Git\\cmd\\git.exe"

$svn
[1] ""

R version 3.5.1 (2018-07-02)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 17134)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252 
[2] LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets 
[6] methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.5.1 tools_3.5.1   

SysInfo:
          sysname           release           version 
        "Windows"          "10 x64"     "build 17134" 
         nodename           machine             login 
"DESKTOP-A3TAVHK"          "x86-64"           "husam" 
             user    effective_user 
          "husam"           "husam" 

R Version:
               _                           
platform       x86_64-w64-mingw32          
arch           x86_64                      
os             mingw32                     
system         x86_64, mingw32             
status                                     
major          3                           
minor          5.1                         
year           2018                        
month          07                          
day            02                          
svn rev        74947                       
language       R                           
version.string R version 3.5.1 (2018-07-02)
nickname       Feather Spray               
$ALLUSERSPROFILE
[1] "C:\\ProgramData"

$APPDATA
[1] "C:\\Users\\husam\\AppData\\Roaming"

$CLICOLOR_FORCE
[1] "1"

$CommonProgramFiles
[1] "C:\\Program Files\\Common Files"

$`CommonProgramFiles(x86)`
[1] "C:\\Program Files (x86)\\Common Files"

$CommonProgramW6432
[1] "C:\\Program Files\\Common Files"

$COMPUTERNAME
[1] "DESKTOP-A3TAVHK"

$ComSpec
[1] "C:\\WINDOWS\\system32\\cmd.exe"

$configsetroot
[1] "C:\\WINDOWS\\ConfigSetRoot"

$DISPLAY
[1] ":0"

$DriverData
[1] "C:\\Windows\\System32\\Drivers\\DriverData"

$FPS_BROWSER_APP_PROFILE_STRING
[1] "Internet Explorer"

$FPS_BROWSER_USER_PROFILE_STRING
[1] "Default"

$GFORTRAN_STDERR_UNIT
[1] "-1"

$GFORTRAN_STDOUT_UNIT
[1] "-1"

$HOME
[1] "C:/Users/husam/OneDrive/Documents"

$HOMEDRIVE
[1] "C:"

$HOMEPATH
[1] "\\Users\\husam"

$LOCALAPPDATA
[1] "C:\\Users\\husam\\AppData\\Local"

$LOGONSERVER
[1] "\\\\DESKTOP-A3TAVHK"

$MSYS2_ENV_CONV_EXCL
[1] "R_ARCH"

$NUMBER_OF_PROCESSORS
[1] "8"

$OneDrive
[1] "C:\\Users\\husam\\OneDrive"

$OS
[1] "Windows_NT"

$PATH
[1] "C:\\Program Files\\R\\R-3.5.1\\bin\\x64;C:\\Rtools\\bin;C:\\Program Files (x86)\\Common Files\\Oracle\\Java\\javapath;C:\\ProgramData\\Oracle\\Java\\javapath;C:\\Program Files (x86)\\Intel\\iCLS Client\\;C:\\Program Files\\Intel\\iCLS Client\\;C:\\WINDOWS\\system32;C:\\WINDOWS;C:\\WINDOWS\\System32\\Wbem;C:\\WINDOWS\\System32\\WindowsPowerShell\\v1.0\\;C:\\Program Files (x86)\\Intel\\Intel(R) Management Engine Components\\DAL;C:\\Program Files\\Intel\\Intel(R) Management Engine Components\\DAL;C:\\Program Files (x86)\\Intel\\Intel(R) Management Engine Components\\IPT;C:\\Program Files\\Intel\\Intel(R) Management Engine Components\\IPT;C:\\Program Files (x86)\\Microsoft SQL Server\\Client SDK\\ODBC\\130\\Tools\\Binn\\;C:\\Program Files (x86)\\Microsoft SQL Server\\140\\Tools\\Binn\\;C:\\Program Files (x86)\\Microsoft SQL Server\\140\\DTS\\Binn\\;C:\\Program Files (x86)\\Microsoft SQL Server\\140\\Tools\\Binn\\ManagementStudio\\;C:\\Program Files\\Git\\cmd;C:\\WINDOWS\\System32\\OpenSSH\\;C:\\Program Files\\R\\R-3.5.1\\bin;C:\\Program Files\\CMake\\bin;C:\\Rtools\\bin;C:\\Users\\husam\\AppData\\Local\\Microsoft\\WindowsApps;C:\\Program Files\\Microsoft VS Code\\bin;C:\\Users\\husam\\AppData\\Local\\GitHubDesktop\\bin;%USERPROFILE%\\AppData\\Local\\Microsoft\\WindowsApps;"

$PATHEXT
[1] ".COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC"

$PROCESSOR_ARCHITECTURE
[1] "AMD64"

$PROCESSOR_IDENTIFIER
[1] "Intel64 Family 6 Model 142 Stepping 10, GenuineIntel"

$PROCESSOR_LEVEL
[1] "6"

$PROCESSOR_REVISION
[1] "8e0a"

$ProgramData
[1] "C:\\ProgramData"

$ProgramFiles
[1] "C:\\Program Files"

$`ProgramFiles(x86)`
[1] "C:\\Program Files (x86)"

$ProgramW6432
[1] "C:\\Program Files"

$PSModulePath
[1] "C:\\Program Files\\WindowsPowerShell\\Modules;C:\\WINDOWS\\system32\\WindowsPowerShell\\v1.0\\Modules"

$PUBLIC
[1] "C:\\Users\\Public"

$QT_D3DCREATE_MULTITHREADED
[1] "1"

$R_ARCH
[1] "/x64"

$R_COMPILED_BY
[1] "gcc 4.9.3"

$R_DOC_DIR
[1] "C:/PROGRA~1/R/R-35~1.1/doc"

$R_HOME
[1] "C:/PROGRA~1/R/R-35~1.1"

$R_LIBS_USER
[1] "C:/Users/husam/OneDrive/Documents/R/win-library/3.5"

$R_USER
[1] "C:/Users/husam/OneDrive/Documents"

$RMARKDOWN_MATHJAX_PATH
[1] "C:/Program Files/RStudio/resources/mathjax-26"

$RS_LOCAL_PEER
[1] "\\\\.\\pipe\\15334-rsession"

$RS_RPOSTBACK_PATH
[1] "C:/Program Files/RStudio/bin/rpostback"

$RS_SHARED_SECRET
[1] "63341846741"

$RSTUDIO
[1] "1"

$RSTUDIO_CONSOLE_COLOR
[1] "256"

$RSTUDIO_CONSOLE_WIDTH
[1] "80"

$RSTUDIO_MSYS_SSH
[1] "C:/Program Files/RStudio/bin/msys-ssh-1000-18"

$RSTUDIO_PANDOC
[1] "C:/Program Files/RStudio/bin/pandoc"

$RSTUDIO_SESSION_PORT
[1] "15334"

$RSTUDIO_USER_IDENTITY
[1] "husam"

$RSTUDIO_WINUTILS
[1] "C:/Program Files/RStudio/bin/winutils"

$SESSIONNAME
[1] "Console"

$SystemDrive
[1] "C:"

$SystemRoot
[1] "C:\\WINDOWS"

$TEMP
[1] "C:\\Users\\husam\\AppData\\Local\\Temp"

$TERM
[1] "xterm-256color"

$TMP
[1] "C:\\Users\\husam\\AppData\\Local\\Temp"

$USERDOMAIN
[1] "DESKTOP-A3TAVHK"

$USERDOMAIN_ROAMINGPROFILE
[1] "DESKTOP-A3TAVHK"

$USERNAME
[1] "husam"

$USERPROFILE
[1] "C:\\Users\\husam"

$windir
[1] "C:\\WINDOWS"

 [1] ".GlobalEnv"        "tools:rstudio"    
 [3] "package:stats"     "package:graphics" 
 [5] "package:grDevices" "package:utils"    
 [7] "package:datasets"  "package:methods"  
 [9] "Autoloads"         "package:base"

#4

Normally, there should be diagnostic information at the bottom of the report as well (reporting different errors, if any, that occurred while RStudio was running). Did you exclude that when copying the report here, or was there really nothing?


#5

Thats all there was in that file that was created. Nothing was displayed passed that.


#6

Been doing some more testing and it seems like Windows closes down Rstudio when it uses ~20+% CPU usage after unlocking my computer (not putting in sleep or anything). I tested it with other programs and this does not happen. Just to add some more context


#7

Update: I uninstalled Rstudio 1.2.1070 and installed Rstudio v 1.1.463 and now I am not seeing the issue. I ran the same tests I mentioned and everything works fine now. I can try re-installing 1.2.1070 to see if a simply re-install would do the trick