R (v4.2.0) graphics engine version 15 is not supported by RStudio-server 2022.02.3+492 - on Ubuntu 20.04

I am using rstudio-server on ubuntu 20.04 WSL, and after updating R to v4 I got the following warning:

Warning message:
R graphics engine version 15 is not supported by this version of RStudio. The Plots tab will be disabled until a newer version of RStudio is installed.

I then uninstalled RStudio-server using

sudo apt-get remove rstudio-server -y

and installed the latest version ( 2022.02.3+492) from here .

Installation was successful but the warning is still present.

I see from the reply to this post that graphics engine v15 support has already been added to Rstudio in 2021, so I am at a loss as to why the warning is persisting...

I am at a loss as to what the issue is here... any help would be much appreciated!
Many thanks!!

Here details of the R and RStudio installations, as obtained from RStudio interface

RStudio 2022.02.3+492 "Prairie Trillium" Release (1db809b8323ba0a87c148d16eb84efe39a8e7785, 2022-05-20) for Ubuntu Bionic
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.67 Safari/537.36 OPR/87.0.4390.36
R version 4.2.0 (2022-04-22) -- "Vigorous Calisthenics"
Copyright (C) 2022 The R Foundation for Statistical Computing
Platform: x86_64-pc-linux-gnu (64-bit)
1 Like

I tried reinstalling once more, and this time I stopped rstudio-server before removing it (only difference compared with previous reinstall) and now the plots are visualised, so the error is solved!... but now view() does not work any more, so I can't view tables in Rstudio... the command runs but no output is generated...

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.