R version not consistently given when start RStudio

I just updated both R and RStudio to versions 4.0.2 and 1.3.1056 (both for PC desktop), respectively. However, I had a similar problem with R v. 4.0.1 and RStudio v. 1.3.959, which I was optimistic would now be fixed based on this: https://community.rstudio.com/t/r-version-no-longer-given-when-start-rstudio/69524, but it is not (at least not entirely). Here is what is happening:

  • EDIT: Today (8/13), it did show the R version when I opened RStudio "cold." So, across my original post and the edits I've made, it's acting inconsistently in general (unless it's been fixed?!). ORIGINAL TEXT: With the latest versions (4.0.2 and 1.3.1056), If I launch RStudio "cold" (i.e., not by double-clicking and opening an R script), I do not see the usual R information in the console, including the version number, etc. (see below).
  • EDIT: This did not work today when I opened RStudio by opening a .R file. ORIGINAL TEXT: However, if I launch RStudio via a script (double-clicking and opening a .R file), then this information does load. This is a slight improvement over what happened with the past two versions I listed above (4.0.1 and 1.3.959), where the R information never showed no matter how RStudio was opened. That being said, it would still be preferable to see the R information no matter how RStudio is opened.

Namely, I'm talking about this information you see if you were to open R directly (or, in the past, RStudio):

R version 4.0.2 (2020-06-22) -- "Taking Off Again"
Copyright (C) 2020 The R Foundation for Statistical Computing
Platform: x86_64-w64-mingw32/x64 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

I know it's minor and clearly you can find out what R version you're using via alternate means, but I am hopeful this can be fixed in the near future.

This isn't an issue for me personally, but I'm an educator, and trying to create screenshots and videos while also explaining to students why things only work some of the time is not ideal (especially when they're already overwhelmed by learning to code and the actual course material).

I just update to R version 4.0.2 and RStudio version 1.3.1073 on a MacBook Pro running MacOS 10.14.6 and I have the same problem. Did you find how to solde it?

Actually, it started working for me in the version I was using (1.3.1056) after a few days. I have since updated to the same version as you (1.3.1073), but for a PC, and it has worked all but once. The only time it hasn't shown this information was once when I opened RStudio directly (not by double-clicking a .R file). However, I closed it and reopened it the same way, and then the version information was there. So...I guess still not entirely consistent, but it at least hasn't done it often for me. Good luck.

Thank you for your answer. I will wait and see if it improves in a few days.

I have the exact same issue @mjean ! It annoys me so much!

Sorry to hear that. I noticed that the R version seems to always be shown when I open a project that contained files in the source editor when it was previously closed. So now I always leave one open and it seems to solve the problem. Hope this tip can help you too.

1 Like

Here's the github issue Ron on the QA team filed for this.
You can track the progress of resolving the bug there.

In the meantime, when in doubt, you are able to get this information via a number of R functions.

R.version # returns most of your platform information
Sys.getenv() # returns environment info, including language and time zone. 
Sys.getlocale() # returns just time settings.  
1 Like

Hi all! First, I was able to reproduce the problem, and I can confirm that it will be fixed in the upcoming 1.4 Wax Begonia release which is currently in development. Second, I appreciate all of your information above, as it helped come up with a precise set of reproducible steps, so thank you!

Ron Blum
Quality Assurance Engineer, RStudio IDE Team

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.