Rcmdr not available

package-installation
#1

Hi, I'm new to rstudio, and am hoping to use R commander as an easier GUI. When I try to install the package using install.packages("Rcmdr", dependencies = TRUE) I get the message:

Warning in install.packages :
package ‘Rcmdr’ is not available (for R version 3.4.4)

I can't find any reference to this problem in the forums, can anyone suggest a solution?
Thank you!

I should add that I am using Ubuntu 17.10, R Studio Version 1.1.463

0 Likes

#2

When you go on CRAN page for Rcmdr you'll see that it depends on R > 3.5.0.

This is why, the package is not available to you - you should not find it in the table available.packages() that filters by default according to the R version. See ?available.packages about built in filter.

As you are on R version 3.4.4, you'll need to install a former version. Previous one, 2.5.0 should be fine according to the DESCRIPTION file from this version

Try something like

remotes::install_version("Rcmdr", "2.5.0")

and see how it goes.

1 Like

Not able to install R commander (Rcmdr) in rstudio
#3

That's great, thank you for your help.

0 Likes

#4

Is this working for you ?

If your question's been answered, would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

0 Likes

#5

Unfortunately this isn't working for me, I can install R Commander version 2.5.0 using that command, but it then attempts to install package 'rgl' as a dependency. This installation fails, with the message:

configure: error: missing required header GL/glu.h
ERROR: configuration failed for package ‘rgl’

Any suggestions...? Thank you for your help!

0 Likes

#6

So the error is different so the solution is working but you now encounter another issue, which is more typical

You are missing some system requirement for the :package: you want to install. Rcmdr seems to suggest rgl that needs OpenGL and friends. See System requirements on the CRAN page
https://cran.r-project.org/web/packages/rgl/index.html

SystemRequirements: OpenGL, GLU Library, XQuartz (on OSX), zlib (optional), libpng (>=1.2.9, optional), FreeType (optional), pandoc (>=1.14, needed for vignettes)

You need to make those available on your system.

About dependencies, normally, remotes::install_version("Rcmdr", "2.5.0"), as I mentionned in my solution, default to not installing suggestes :package: . Maybe you ran remotes::install_version("Rcmdr", "2.5.0", dependencies = NA, dependencies = TRUE) that will also install Suggests :package: (or there is a change in default value)

As rgl is in suggest, you may be able to not install Rcmdr without it using the correct argument for dependencies

0 Likes

closed #7

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes