Read Only File System Error in RStudio Cloud

I am suddenly getting a "Read Only File System" Error. There doesn't seem to be any reason for this. Started happening suddenly. I saw a similar post from January where RStudio employee asked that user run df -h in terminal. Here are the results I am getting the following information:

Filesystem Size Used Avail Use% Mounted on
overlay 125G 27G 98G 22% /
tmpfs 64M 0 64M 0% /dev
tmpfs 16G 0 16G 0% /sys/fs/cgroup
/dev/nbd52 2.7G 1.1G 1.5G 43% /home/rstudio-user
/dev/nbd54 2.7G 481M 2.1G 19% /cloud/project
/dev/nvme0n1p1 125G 27G 98G 22% /opt/R
shm 64M 0 64M 0% /dev/shm
/dev/nbd53 2.7G 165M 2.4G 7% /home/rstudio-user/.rstudio
/dev/nbd55 2.7G 745M 1.9G 29% /home/rstudio-user/R
tmpfs 16G 4.0K 16G 1% /etc/rstudio/license
tmpfs 16G 0 16G 0% /proc/scsi
tmpfs 16G 0 16G 0% /sys/firmware

Hi Michael,

Can you please post the URL for your project?



Thanks for responding so quickly. Fortunately, after a few hours, the issue disappeared so not sure you would be able to trouble-shoot any further. Two follow up items:

First the URL is if you still wanted it.

Second, I've had two issues in the past week that caused my project to be unusable only to have time resolve the issue. In both cases, it was immediately after using ggplot2. It may obviously just be coincidence but is there anything I need to be aware of when using ggplot2 and RStudio Cloud?


Hi Michael,

Can you provide more detail on what you mean by unusable? Also, how much memory are you using for your project? Depending on the type of analysis you're running and the size of the data, you could be running low on memory (default is 1GB). Since you're on a premium plan, you could go up to 8GB per project by changing the project settings - see: for more details.

I hope this helps,


Sure. Here's some additional insight regarding your questions. First, currently using 1.5GB of memory. Happy to increase if that might be an issue.

Second, in terms of what I mean by unusable. I've had two situations in the last week where I was unable to use the project for several hours. Here's a quick summary of both situations:

"The previous R session was abnormally terminated due to an unexpected crash. You may have lost workspace data as a result of this crash".
Six days ago, I was working in this project and started getting the error above. I tried Terminating R, Restarting R, Closing and Reopening the browser and no matter what I did, I would continue to get this error. The following morning the project was back to normal.

Read Only File System Pop-Up
The second issue, unrelated to the first but with similar consequences, is the item referred to in this post. When I would open the project, I would get a pop-up that said "Read Only File System". Then the project would open as normal with two exceptions. First, I couldn't use write_csv, write_rds, etc. to write data to a file. I would either get an error that the system could not create the connection or that the specified directory did not exist (although it did). Please note that internet connection was fine as I was able to read data and run scripts. Second, the "git" tab was missing entirely from IDE.

Again, I tried repeatedly to restart, terminate, etc. and nothing worked. After a few hours, project returned to normal behavior.

Hope that helps and if you have any advice, please let me know. In both cases, all functionality returned to normal but that's obviously not a long term solution for me. If there's something I need to be doing differently, will be happy to change process.


Hi Mike,

I am very sorry about the trouble you're having with your RStudio Cloud projects. I'll try and speak to both problems you ran into to see if I can help get to the bottom of what is going on.

"The previous R session was abnormally terminated due to an unexpected crash. You may have lost workspace data as a result of this crash".

This sounds a bit like it might be caused by running out of memory. By default, projects are limited to 1GB of memory. Unfortunately, our logs do not back far enough for me to able to confirm if you did in fact run into this limit. But I would suggest increasing your memory resources if not have not already done so.

Read Only File System Pop-Up

We have a theory about what might have caused this, but I'll need a little more information. Do you have an approximate time window for when your project experienced the "Read-Only filesystem" popup so we can investigate further?

Additionally, when you saw this error, did you attempt to relaunch the project?

Screen Shot 2020-10-01 at 2.25.45 PM



Thanks for getting back to me. In response to your questions:

First, I did not try Relaunching the project. Tried re-starting and terminating but didn't think of Relaunch. Thanks for the heads up, will try that if it happens again.

Second, your comment on memory seems plausible. It's a fairly large dataset with some fairly intense number crunching. I did upgrade from .5GB default to 1.5GB shortly after the original issue and haven't had it since. Is there some easy way to tell if I need to allocate more memory while running some of the more memory intensive scripts?

Third, the "Read Only File System" issue occurred at approximately 11:40 - 11:45 AM Central Time on 2020-09-30. I can't tell you exactly when it started but I have a record of sending a text to my colleague letting him know I was having issues at 11:49 AM so it was obviously some time before I sent that text.

Hope that helps and let me know if you need anything else.


Unfortunately, the only way for end users to know they might be running into memory problems is if they see the crash notification message that you reported. Sometimes the problem will manifest in other ways (such as a package failing to install). We're aware this is a poor user experience, so we're currently investigating ways to expose these out of memory conditions in the UI, or perhaps other memory usage indicators.

Thanks for the information about the Read-Only file system. I'm taking a look now to see what I can find.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.