Reload App not working on newest IDE release?

The Reload App button to reload a running shiny app worked perfectly, but on updating to the newest RStudio ( RStudio Desktop 1.3.1056 for Windows), I get the error message:

Error Saving File

Exception caught: (TypeError) : Cannot read property 'id' of null

This happens for all of my shiny apps, even the Old Faithful one that comes "preshipped" when openeing a new shiny application (with ui.r and server.r files).

After the update, RStudio IDE seem to have a problem of writing the edited ui.r file to disc on pressing "Relaoad App" that wasn't there before.

After downgrading to Version 1.2.5042 the issue did not show up and everything worked fine.

1 Like

I am facing the same issue.

R-Studio Desktop 1.3.1056 (Open Source)

Below are additional snapshots from Inspect element if it is of any help.

The error pops up when we try to reload the app without saving the changes in file(s). The save before build option is active. Additionally, the app window used to jump to the top after the Reload App button was clicked. But that also is affected with this.



This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.