remotes package

Dear all,

Getting below error from trying to install packages from github directly via this remotes package. We are using Rstudio pro installed in SLES linux server.

library(httr)

options(download.file.method = "auto")

remotes::install_github("r-lib/conflicted")

Error: Failed to install 'unknown package' from GitHub:
Timeout was reached: [api.github.com] Operation timed out after 10000 milliseconds with 0 out of 0 bytes received

Since the conflicted package exists at the location you specify, and since your syntax is correct, this is possibly related to a networking issue.

So my first question is whether this server can usually reach out to the internet? Are you able to install packages from CRAN? Can you ping the github site from this server (on the linux command line)?

The second networking issue you should check is whether you're using a proxy or not. If your proxy is cauing the problem, see the advice at 'install_github' gives timeout reached error · Issue #877 · r-lib/devtools · GitHub, specifically:

library(httr)
with_config(use_proxy(...), install_github(...))

OR

library(httr)
set_config(use_proxy(url = "******_", port = "_*"))
devtools::install_github("username/packagename")

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.