reprex packages

Hello,

I've made several post and at each time I've received the message that I have to use reprex. what I understand well!

So, I tried to use the reprex package without success.
I installed the package reprex and I have the message :

Error: object 'reprex' not found

Thanks in advance to your help!

What prompted the message? If you ran a line of code that just said reprex, this is what I would expect to see.

If you have the code you'd like to render as a reprex on your clipboard you need to either run library(reprex) beforehand and just run reprex() in the console, or run reprex::reprex() in the console with the namespace prefixed.

FYI, if you've installed library(tidyverse) you already have reprex installed. :slightly_smiling_face:

I run library(reprex) and reprex(), that's ok I ve my prog in clipboard.

But, I have a lot of warning because it can't open the file (test2.csv)

Have you an idea?

Yep. reprexes have to be self-contained, so it's likely it doesn't know where test2.csv is. That's not a bad thing, because no one else has that file either, so they wouldn't be able to reproduce your work anyhow!

See this thread for how to include your data in a reprex:

I also recently wrote up a quick post with gifs on how to use datapasta with reprex here:
https://reprex.tidyverse.org/articles/articles/datapasta-reprex.html

3 Likes