restart footnote numbering in each chaptering

Continuing the discussion from Getting footnotes to restart at each chapter in bookdown:

Is this possible? I'm also running into very high numbers with my footnotes in a book I'm currently working on.

I don't think this is supported today. You can open a feature request as we can think about how to do that.
Thank you !

Currently, as often, you may be able to post process your book so that you renumbered the footnotes. But as often, it is just a workaround.

Interesting. I just noticed that the footnotes in my PDF and my ePub start over at 1 for each chapter. It is only the web version where they are wrong.

Is there a setting where I can make each chapter processed by itself first, and then combined (for the web version)?

At the very least I'd think that everybody wants their footnotes to work consistently across the various output files.

I just noticed that the footnotes in my PDF

This comes from latex itself with the book format, it resets the footnote each chapter. see the doc of the book class and https://www.texfaq.org/FAQ-run-fn-nos

For EPUB, it seems it is handled by the format directly too.

For HTML, a solution in javscript or a post processing. You can give a :+1: here


Some solutions are provided there, not yet included inside bookdown. Could be one day to be consistent as you said.

Hope it helps

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.