RFM package in R Studio

Hello R programmers,

I am completely new to R programming, so apologies if my question is silly but I would really appreciate if someone can help me out.

I have ben running the rfm package and different rfm functions ( rfm-result, rfm_table_order,etc) successfully since the last 2 days. However when I ran the same code today, I get the below error message. I am not sure what to do. I have re-installed and updated the rfm package, but nothing works. I find it strange the code ran perfectly one day and the next day it does't. Please help!

This my code:
rfm_result <- rfm_table_order(data = food_rfm, CompanyIDName, PostingDate, Revenue, analysis_date)

This is the error I get:
Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
namespace ‘ellipsis’ 0.3.1 is being loaded, but >= 0.3.2 is required

This is asking you to update the ellipsis package

1 Like

Hi Andresrcs,

Thank you so much for the suggestion, it worked perfectly for me :slightly_smiling_face:! I think I need to understand the error log well to anticipate the solution.

in general you dont want this in your script, its a needless waste of time, to install what is installed from your previous time you ran the code.
you could comment it out

my code
# my code that is commented out
my code again

It's also worth noting that this is a sign that you have custom .libPaths that might not be allowing package updates automatically when installing a desired package.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.