RJDBC works in bare R Gui, not in RStudio

SOLVED: see below.

I am able to run the following in the base R Gui, but when I run the same commands from the R console window in RStudio, I get a "Session Aborted" message and I have to restart the application and reopen my session.

RStudio information:

2022.02.3 Build 492

R GUI (successful run):

R version 4.2.0 (2022-04-22 ucrt) -- "Vigorous Calisthenics"
Copyright (C) 2022 The R Foundation for Statistical Computing
Platform: x86_64-w64-mingw32/x64 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

  Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

During startup - Warning message:
Using locale code page other than 65001 ("UTF-8") may cause problems. 
> library(RJDBC)
Loading required package: DBI
Loading required package: rJava
Warning message:
package ‘RJDBC’ was built under R version 4.2.1 
> vDriver <- JDBC(driverClass="com.vertica.jdbc.Driver", classPath="C:/Users/irinzn/Downloads/vertica-jdbc-12.0.0-0.jar")
> vDriver

> sessioninfo::session_info()
- Session info -------------------------------------------------------------------------------------------------------------------------------------------
 setting  value
 version  R version 4.2.0 (2022-04-22 ucrt)
 os       Windows 10 x64 (build 19043)
 system   x86_64, mingw32
 ui       Rgui
 language (EN)
 collate  English_United States.1252
 ctype    English_United States.1252
 tz       America/Chicago
 date     2022-07-07
 pandoc   NA

- Packages -----------------------------------------------------------------------------------------------------------------------------------------------
 ! package     * version date (UTC) lib source
   cli           3.3.0   2022-04-25 [1] CRAN (R 4.2.0)
   DBI         * 1.1.2   2021-12-20 [1] CRAN (R 4.2.0)
 D rJava       * 1.0-6   2021-12-10 [1] CRAN (R 4.2.0)
   RJDBC       * 0.2-10  2022-03-24 [1] CRAN (R 4.2.1)
   sessioninfo   1.2.2   2021-12-06 [1] CRAN (R 4.2.1)

 [1] C:/Users/irinzn/R/R-4.2.0/library

 D -- DLL MD5 mismatch, broken installation.


RStudio information:

2022.02.3 Build 492

SOLVED: Via installing R 4.2.1patched, see here: RStudio session aborted when loading some packages after upgrade to R 4.2

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.