Rmarkdown citation style with BibTex: How do I change citation style?


So I am not sure if this is more of a question on how rmarkdown integrates LaTeX or if it is a question on LaTeX itself, but I am trying to change to citation style in a paper I am writing. My citations all have ()'s around the year and I would like some to have parenthesis around the author as well as the year.

Also, I don't know if it makes a difference but I am using Zotero to make my BibTeX file.


title: "Phase Picking from Seismic Wave-forms: A deep learning application for identifying earthquakes"
author: "Bryan R Thomas"
header-includes: \usepackage{amsmath}
date: "5/1/2021"
output: pdf_document
bibliography: path_to_paper/sac2EqT_paper.bib

BibTeX Item

	title = {{sac2EQTransformR}},
	copyright = {GPL-3.0 License         ,                 GPL-3.0 License},
	url = {https://gitlab.com/Bryanrt-geophys/sac2eqtransformr},
	abstract = {Wrangle by-hand seismic waveform label data from methods such as SEISMOS and build a retraining model for the deep-learning packages such as EQTransformer},
	urldate = {2021-05-03},
	author = {Thomas, Bryan},
	month = apr,
	year = {2021},
	file = {Snapshot:/Users/jolante/Zotero/storage/VP4W5VN4/sac2eqtransformr.html:text/html},


I have been experimenting with the \setcitestyle{} command but I am not having much progress.

I can successfully place a reference from my .bib file with something like@thomas_sac2eqtransformr_2021 referencing the citation info from my .bib file. This yields

Thomas, Bryan (2021)

and If I use \citep{@thomas_sac2eqtransformr_2021} to try to use the setcitestyle preferences I set in the YAML, I'm returned with


It appears that my setcitestyle preferences are working but I can't pass my .bib handle the way I did before. Does anyone have experience with this that they could share? All help is apreciated.