Rows 'unsort' when viewing columns 50+ in Data Viewer

I have a dataset with 85 columns and (>7000 rows). I recently upgraded to RStudio 1.3 and the data viewer only shows 50 columns at a time. When exploring the dataset, if I sort based on a column (say column 3) by clicking in the header, when I click to view columns 50-85, the sorting disappears and it reverts to the original row order. Is this a known bug? is there a way to prevent it doing this? Or can I disable the column limit?
Thanks

perhaps an alternative to the viewer is something like the DT package, for rendering a table of data using web technology (javascript)

library(DT)
DT::datatable(mtcars)

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

Thanks, this was very helpful and works pretty well (I get a warning about my data being too big but it works anyway).