rs-connect deployment does not halt even after app. is successfully deployed

Hello Everyone,

I am facing with an unusual issue while deploying the applications from my local machine on the rs-connect server.

The application gets successfully deployed on the server; but the deployment window in my local machine does not stop. Because of this I am not able to make another deployment unless I restart my RStudio (v 1.2.1070). I am not able to pin-point the root-cause of this. Below are the snapshots

Step I : Deployment starts normally

Step II : The app is deployed on the server. The below snapshots note the date time of deployment and the console output

Step III : The deploy window should ideally stop executing and open the application in a web browser. But this does not happen. I get a continuous stream of statuses

I tried to see what is causing this issue from task manager and it was the curl.exe that was getting continuously executed. I am not sure how to proceed further this step.

Image_III

Any help is much appreciated.

Thank you in advance!

Because this discussion involves an RStudio Pro product, it was referred to RStudio Premium Support.

Should a generalizable solution exist, it will be shared below.

If you have a related issue, please open a New Topic.

Hi Curtis,

Just a quick fyi. This might not be an issue with rs-connect. My other colleagues are using different version of RStudio (version 1.1.456) and they are not facing this issue.

I short-listed 2 options; 1. A bug in the preview release of RStudio-1.2.1070 or 2. The version of curl on my local machine. I am confused which of these two is the root-cause.

Thanks!
Heramb

1 Like

The development versions of rsconnect will use the curl program by default for deployments, if available on the machine. We install this version by default in the preview release of RStudio, so that's perhaps why you're seeing this.

Can you provide the output of Sys.which("curl")?

Sys.which("curl")
                             curl 
"C:\\WINDOWS\\SYSTEM32\\curl.exe" 

It is using the default curl.exe (version - curl 7.55.1 (Windows) libcurl/7.55.1 WinSSL).

I saw two new .exe QtWebengine.exe and winpty-agent.exe in the bin folder, which are not present in earlier versions. But even after reverting the RStudio's version to 1.0.136, the issue persisted.

Thanks!
Heramb

1 Like

What version of the rsconnect package do you have installed? (What does packageVersion("rsconnect") report?)

Does installing the version of rsconnect currently on CRAN help?

packageVersion("rsconnect")
[1] ‘0.8.10’

The latest package on CRAN is 0.8.8 . I tried to install that and then publish the application with same bug.

But another interesting thing I found out was, rsconnect version was over-ridden by the 0.8.10 from devtools everytime I re-started my RStudio. I had to uninstall it and re-install CRAN-version through a .tar.gz everytime.

Thanks!
Heramb

Preparing to deploy application...DONE
Uploading bundle for application: 95...DONE
Deploying bundle: 479 for application: 95 ...

It is at the 3rd step that it doesn't mark as DONE when in reality that step is actually completed in the back-end.

Thanks!
Heramb

Hi Kevin,

The issue got resolved with installing rsconnect - 0.8.8 from CRAN. But there is pre-saved rs-connect - 0.8.10 in RStudio packages (image below) which always over-rides the CRAN installation and needs to be deleted.

Also, this pinpoints the issue to rsconnect 0.8.10 on gitHub

Thanks!
Heramb

We're now tracking this here:


We'll try to get this fixed up soon!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.