rsDriver error when executed through company's network

I am facing an issue while running the rsDriver() function to open up the chrome browser.

library("RSelenium") library("wdman") mybrowser <- rsDriver(browser=c("chrome"), chromever="80.0.3987.16",port = 443L) remDr <- mybrowser$client remDr$navigate("") Sys.sleep(2)

When I run this code on my machine while connected to my home network the code works as expected. But when I run this code from my office network, the rsDriver(browser=c("chrome"), chromever="80.0.3987.16",port = 443L) gives me the below error and I am stuck at this point.

checking Selenium Server versions:
Error in open.connection(con, "rb") : 
Timeout was reached: [] Operation timed out after 10000 milliseconds with 0 out of
0 bytes received

I tried connecting through the company's proxy with the below code but still no luck. I tried using the port numbers 4444,4445,4567 but still the same error.

cprof <- list(chromeOptions = list(args = list("--proxy-server=")))
mybrowser <- rsDriver(browser=c("chrome"), chromever="80.0.3987.16", port = 443L,extraCapabilities = cprof)

It would be very helpful someone can help me in understanding the issue and suggest me a solution. Am I missing something in the code. Any help would be highly appreciated. Also do let me know for any additional information required.

Cross-posted below,

From: FAQ: Is it OK if I cross-post?

Posting the same question to multiple forums at the same time is often considered impolite. We don't completely ban such cross-posting, but we ask you to think hard before you do it and to follow some rules.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.