rsession-exec-command value returns error in /etc/rstudio/rserver.conf

Hi everyone,

I am trying to follow the steps in the RStudio Server Professional Edition documentation and am having some trouble. It is running on Ubuntu 18.04.1 server, rstudio-server 1.1.456.

I would like for scripts to be run at a different priority. According to the documentation, I should be able to use the rsession-exec-command setting in /etc/rstudio/rserver.conf. I even used the same line as in the config file:

rsession-exec-command=nice -n 10

However, when I add this command, the rstudio-server service fails to restart. Checking the rstudio-server systemctl log shows the following:

ERROR Error reading /etc/rstudio/rserver.conf: unrecognised option 'rsession-exec-command'; LOGGED FROM: rstudio::core::ProgramStatus rstudio::core::program_options::read(const rstudio::core::program_options::OptionsDescription&, int, char* const*, std::vector<std::basic_string<char> >*, bool*, bool) /home/ubuntu/rstudio/src/cpp/core/ProgramOptions.cpp:152

Am I missing something glaring here, or has this setting been removed?

Thanks in advance!

The "Program Supervisors" feature described in the documentation is only available in RStudio Server Pro, which is why you are seeing the error that it is an unrecognized option in the open-source version.

You can see what is included in the open-source version vs. the Pro version in the documentation:

And you can download and install an evaluation version of RStudio Server Pro from to configure this and other settings that are only available in the Pro version.

Thank you for the prompt and concise answer! I will forward your reply to the faculty whom I support and see if we should purchase the Pro version.


You're welcome!

Note that for qualified institutions we have discounted licenses of RStudio commercial products per our Academic Pricing Policy.

And you can install and configure RStudio Server Pro with a 45-day evaluation in the mean time to make sure things are working in your environment as you expect.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.