RStudio 1.1.456 and 1.1.383: "Session->New Session" Not Creating New Session

ide-bug

#1

Hi folks,

I have need to run Windows RStudio (using 1.1.456 but also reproduced on 1.1.383) under a different elevated account to my regular login account because the elevated account has read-only access to production databases.

I've started using Projects and wanted to open a Project in a new session via the "Open Project in New Session..." option on the right hand side. When I select "Open Project in New Session..." the menu option goes away but no new session is open. Also, when I select "Session->New Session", no new session is open either.

I also noticed that if I run RStudio without the Windows "Run as different user" option, this symptom goes away.

Minimal steps to reproduce are:

  • Open RStudio using "Run as different user" and selecting an alternate user account
  • Select "Session" menu
  • Select "New Session"
  • Expected result: Menu closes and a new RStudio session opens up
  • Actual result: Menu closes but the new RStudio session doesn't materialise. Existing RStudio session continues to operate and be responsive to user input

Is there anything I can do to run RStudio under an alternate account and have the "Open Project in New Session..." or "Session->New Session" menu options work? Please let me know if I need to make the reproduction instructions clearer.

I have a workaround which involves creating a Windows shortcut to the "runas" utility which will open up a new session for me as desired.

Regards,

Kevin