Rstudio 1.2.637 displays "This site can’t be reached" upon startup


#1

Rstudio on Debian Buster (rstudio-1.2.637-amd64.deb) displays a standard Chrome "connection refused" message. I am connecting via ssh's X11 forwarding. All previous versions (v1.1.xxx) worked without any problems.

Moreover, pull down menus are clickable, but do not show any menus when clicked.

Error messages in command line:

"Uncaught TypeError: Cannot read property 'notifyRCrashed' of undefined"

The content of the windows:

This site can’t be reached

127.0.0.1 refused to connect.
Try:
Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_REFUSED

V1.2.637-1 Preview refused to connect
#2

I tried connecting to the same Debian machine from macOS. The result is an empty window (no error message) and the following stuff in the console:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Unrecognized OpenGL version
Unrecognized OpenGL version
[83165:83233:0524/123647.659418:ERROR:gl_context_glx.cc(239)] Couldn’t make context current with X drawable.
[83165:83233:0524/123647.659446:ERROR:gpu_info_collector.cc(56)] gl::GLContext::MakeCurrent() failed
[83165:83233:0524/123647.659452:ERROR:gpu_info_collector.cc(119)] Could not create context for info collection.
Unrecognized OpenGL version
Unrecognized OpenGL version
QQuickWidget: Failed to make context current
QQuickWidget::resizeEvent() no OpenGL context
QQuickWidget: Failed to make context current
QQuickWidget: Attempted to render scene with no context
[83165:83233:0524/123648.125499:ERROR:gl_context_glx.cc(239)] Couldn’t make context current with X drawable.
[83165:83233:0524/123648.125516:ERROR:gpu_command_buffer_stub.cc(780)] Failed to make context current.
Unrecognized OpenGL version
Unrecognized OpenGL version
Unrecognized OpenGL version
Unrecognized OpenGL version
composeAndFlush: makeCurrent() failed
composeAndFlush: makeCurrent() failed
“Uncaught TypeError: Cannot read property ‘notifyRCrashed’ of undefined”
QQuickWidget: Attempted to render scene with no context
composeAndFlush: makeCurrent() failed

#3

Sorry about the issue.

This might be a good one to post as an RStudio IDE github issue. They'd be keen to diagnose the issue.

If you're working with rstudio-server-pro, I hope you of course know to contact pro support at support.rstudio.com (and probably not use the development version)


#4

Done