Rstudio 1.4.1106 crashes on Ubuntu 20.04.2 LTS

Dear all

I cannot run Rstudio on my newly installed 20.04.2

when i try to generate some tree files i get the
elf_dynamic_array_reader.h(61) tag not found
ERROR directory_reader_posix.cc:42] opendir: No such file or directory (2)

which has been also mentioned herehttps://community.rstudio.com/t/r-studio-crashes-with-fatal-error-elf-dynamic-array-reader-h-61-tag-not-found/93130

i can see there are several posts and this problem has been going on since Rstudio 1.2 but none of the fixes work for me
For the record I tried:
i) switching to a proprietary nvidia driver
ii) Tools > Global options > Advanced > Rendering software
iii) reducing the screen resolution

System details

R version 4.1.0 (2021-05-18) -- "Camp Pontanezen"
QMake version 3.1
Using Qt version 5.12.8 in /usr/lib/x86_64-linux-gnu
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.2 LTS
Release: 20.04
Codename: focal

this is not a fix but a small note that may help to fix this in the future:

I removed R and downgraded to R version 3.6.1 (2019-07-05) and everything seems to be working now - for some reason this is related to the newest 4.1.0

For R 4.1.0 compatibility you have to use the preview version of RStudio

Thanks! Will give it a try and keep everybody updated. Does that mean that hopefully this will be fixed in the next Rstudio version?

Cheers!

I had the same issue (crash when attempting to plot) when R is v 4.1. Installed Preview v 1.4.1717. And the problem is solved.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.