RStudio- refused to connect

Yesterday I was working in RStudio and wanted to use a R package (corrMatrix). It said that it is not available for R 3.5.3. While searching for how to switch to a different version of R in the menu, I came across a box offering lower R versions. It warned me that I should restart the machine if I switch to one of those. I did not do this (biggest stupidity of mine!!!). I was in a hurry and immediately rushed into using RStudio again. I could start it but it only appeared as a blank page with a nonfunctional menu line at the top.

It said and still says:
"This site can’t be reached refused to connect.

Checking the connection
Checking the proxy and the firewall

Attempted steps taken to fix -
I might be a good R-user but I do not have much clue about how all those files of R, RStudio, Jupyter Notebooks, etc. are working behind the screen. After trying a couple of time to use RStudio in the usual way and getting the screen of " refused to connect", I uninstalled R and RStudio and downloaded and installed both of them again. Nothing changed!

In your troubleshooting page, there was this link
( ```
C:\Program Files\RStudio\bin\Run Diagnostics.lnk

to run a diagnostics report. I ran this in the Windows 10 for the first time , it said on the screen something like broken pipe error 0x6 but I think it did not produce the .txt file related to it. Then I tried tens of other things like adding as localhost, taking down the firewall, etc. None of my attempts was succesful. When I run the same diagnostics link again, it does not say anything about the error but the problem is the same. I am a doctoral student, all my codes are in Rscript and RMarkdown files and I cannot use them again because RStudio does not work. 

What should I do now? I will be extremely grateful if you can help me. Thanks a lot in advance. 

#### System Information:
- RStudio Edition: (Desktop or Server) Desktop
- RStudio Version: 1.2.1355
- OS Version: I do not know
- R Version: 3.5.3
- Output your diagnostics report (if possible): 

From [RStudio Desktop Will Not Start on](

Have you tried reseting Rstudio's state?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.