RStudio Cloud hanging

I'm using RStudio Cloud in my classes again this semester (~18 students per section, and the two sections are back-to-back). I created a Space for my class, and put a couple projects in it (a base project with packages, and an initial "assignment" project for students to click on to create derived projects).

I think all my students have been able to create the derived project, which initially worked fine. However, many of my students are now experiencing that project hanging in the loading stage forever (meaning, more than 5 or 10 minutes, including reloading the page in the browser). In one class, all the students had to "Relaunch Project" to get them to work, and that hasn't fully solved the issue (although it did let them get in at the time).

I just opened the project that their projects are derived from, and have an error:

Session version 1.2.1578-4 does not match server version 1.2.1335-1 - this is an unsupported configuration, and you may experience unexpected issues as a result.

Is it possible this is what is causing my students' projects to hang on opening? Is there a fix I (or my students) can do?

The Space is and the Project is

Hi Amelia!

We rolled out a new version rstudio server pro preview over the weekend, and that error message is letting you know. In the past this hasn't actually caused any projects not to open, so I would guess that there is something else at play which is preventing access (given that the 'Relaunch project' button worked, i'm led to believe this is within the IDE session, perhaps overrun memory usage or some project setting/environment-specific feature that is causing things to hang?)

That being said, it is possible you and your students may have discovered a regression in the IDE that is exposed by the switch between the two versions. Does relaunching seem to fix the problem for each project permanently, or it appears again after the project has gone to sleep when it's awoken again?


My students were experiencing this issue last week (September 9 and 11) and again today (September 16). So, I don't think it has anything to do with the upgrade. I was just excited because I saw an error message.

Relaunching does not seem to solve the problem permanently. I'll report back again this afternoon after I've had class again, so far it's just office hours today that have let me know students are still having trouble.

1 Like


Do you mind adding me ( as an admin to your space so I can look into what is going on with this project?


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.