RStudio Cloud is getting crashed everytime I run a long simulation

I don't remember exactly maybe before Feb 2020, I was running a simulation in RStudio web and it supposed to take 7-8 hours and it ran successfully even when I closed the tab on my computer. After 12 hours I open RStudio and see the result is there. I loved the RStudio web so much and done similar simulations without any problem.

After that time, once I found that there is a server problem in the cloud and you guys fixed it within 6 hours. But after this problem my life in RStudio became hell. The same simulation is getting crashed most of the time. I don't know what happened but I have lost my hope on RStudio Web.

Free accounts on RStudio Cloud ar limited to 1GB RAM memory, this makes memory-intensive tasks prone to brake because of lack of memory, try to modify your code to release as much memory as possible among steps.

Sorry to hear about your simulation crashing. If you provide your project URL, we can look further into the cause of the crash.

Omar Baba

Thanks a lot. Here is the URL,

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.