RStudio Cloud PDF not rendering Exercise

Generally the PDF rendering works better for me and my students using then local installations.

One major item that seems to be missing from the's LaTeX system is support for the exercise tag. Putting the following in an RMD, will give a nicely numbered and formatted exercise heading when knitted to PDF on my local installation. It gets ignored in (Knitting to HTML also ignores the exercise chunk, would be nice if it was supported in HTML too.)

```{exercise, name="Revisiting Transportation"}
Using sensitivity analysis, revisit the transportation exercise from chapter 3.  If one more unit of supply was available, where would it be prioritized and why?  If demand could be increased by one unit, would it affect the result and at which destination node it be preferred and why?

It looks like topic system dropped my exercise tagged chunk as well for not being a supported option.

This was inserted as a chunk in my rmd with triple ticks at the beginning and ending.

{exercise, name="Revisiting Transportation"}

I think we dropped the ball in looking into adding xzdec. I think that if it were available you would be able to use tlmgr to install exercise yourself.

xzdec is now installed in our base images.

In order to install additional TeX Live packages you need to do the following:

tlmgr init-usertree
tlmgr option repository
tlmgr --no-persistent-downloads install exercise
1 Like

That being said, I don't know knitr well enough to know how one would register exercise as an engine, so this may not completely solve your problem

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.