Rstudio crash on global options drop-downs, rmarkdown preview

I'm experiencing repeatable crashes in Rstudio on one of my computers, running Windows 10. Compiling Rmarkdown documents works, but when Rstudio attempts to display the resulting document, it crashes. The same goes for clicking on the dropdown menus in the Global Options (so I can't change the output preview as a crude workaround). The window or the dropdown menu will appear but be empty, and then Rstudio freezes up and won't respond.

I've tried (a) restarting computer, recompiling rstudio documents within/not within projects, compiling on a different computer (other computers are fine) (b) compiling other documents on other hard drives on this computer (same bug) (c) uninstalling and re-installing Rstudio (currently v 1.2.5033, 64 bit) (d) uninstalling and re-installing R (currently v 3.6.2), (e) resetting Rstudio configuration by renaming %localappdata%\RStudio-Desktop.

The computer in question is running an intel quad-core i7-6700K CPU, with 32 GB of ram, 64-bit Windows 10.

Any suggestions? Thanks is advance!

Hi, welcome!

Have you tried changing to software rendering?, you can change it by holding the Ctrl key while opening RStudio, then you should see this menu and change the "Rendering Engine" to "Software".

1 Like

Perfect! That did it! Thanks!

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.