RStudio crashes on Ubuntu 18.04 LTS R 3.6.2

I just updated RStudio to 1.2.1059 and now it crashes, usually before it is fully up, but once when I tried to do package updates. No other issues on the system. I removed, re-downloaded and reinstalled but got the same results. I tried to fall back to 1.1.463 but it wouldn't install (it went through the motions, but only took a few seconds, and could not be run). It was working fine before the update.

The logs show:
nouveau 0000:01:00.0: rstudio[7249]: push 0 buffer not in list
nouveau 0000:01:00.0: rstudio[7249]: validate: -2
nouveau 0000:01:00.0: rstudio[7249]: validate_init
nouveau 0000:01:00.0: rstudio[7249]: Unknown handle 0x00000067

all with kernel device +pci:0000:01:00.0

Hi, and welcome!

I haven't been brave enough to go to R 3.6.2 yet, but have no issues with RStudio 1.2.1578 under 19.10 and R 3.6.1.

So my suggestion would be to install 1.2.1578. C'mon back if you have issues.

R 3.6.2 runs OK stand alone, but there may be some issue with RStudio and 3.6.2

I will try falling R back to 3.6.1

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.