RStudio crashes when I open a certain file, but preview version does not

Here's a weird one. Last weekend, I downloaded README.Rmd from here. I seem to remember being able to open and view this file in RStudio 1.1.463 - Ubuntu 16.04+/Debian 9+ (64-bit). No problem.

However, tonight, I tried opening this file in RStudio (by double-clicking the file in Nautilus, as is usual). When I did, RStudio froze, thought for awhile, then crashed. I tried again. Same thing. I even tried copy+pasting the contents of README.Rmd into a new, blank Rmd file created in a new session of RStudio. After a few seconds of this text existing in RStudio, the program freezes and crashes once again.

I purged RStudio, deleted the folders and cache it creates in my home directory at installation, and reinstalled the same version of RStudio for Ubuntu. Same issue. I cannot open README.Rmd without instantly crashing RStudio. I cannot even copy+paste the contents of that file into a new one without a crash a few milliseconds later.

I purged RStudio again. Installed the preview version--RStudio 1.2.1303 - Ubuntu 18 (64-bit)--instead, and tried opening the file. It worked. No crashing.

Does anyone have any ideas about what's going on? It's not terribly urgent, since the problem doesn't occur in the preview version of RStudio, though I'd prefer the stable version.

Here's my session info upon startup of RStudio (preview version now), if that helps:

R version 3.5.2 (2018-12-20)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 18.04.2 LTS

Matrix products: default
BLAS: /usr/lib/x86_64-linux-gnu/blas/
LAPACK: /usr/lib/x86_64-linux-gnu/lapack/

 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C               LC_TIME=en_US.UTF-8       
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                  LC_ADDRESS=C              

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.5.2 tools_3.5.2    yaml_2.2.0   

For what it's worth, we're aiming to release RStudio v1.2 near the end of next month, so the current preview release is very close to what will become our release candidate.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.