RStudio crashes when loading XLConnect (latest install RStudio and R)

I have recently upgraded both RStudio and base R (latest versions). Seems to have solved most issues but trying to launch the package XLConnect causes RStudio to crash. Works fine in Base R:


R version 4.2.0 (2022-04-22 ucrt)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 19044)

Matrix products: default

[1] LC_COLLATE=Swedish_Finland.1252 LC_CTYPE=Swedish_Finland.1252 LC_MONETARY=Swedish_Finland.1252 LC_NUMERIC=C LC_TIME=Swedish_Finland.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

other attached packages:
[1] data.table_1.14.2 RODBC_1.3-19

loaded via a namespace (and not attached):
[1] compiler_4.2.0 tools_4.2.0

I think this is related to this issue

You can try downloading the patched version of R 4.2

Ah - super, that will probably be the reason.

And it was - tried upgrading with the patched version, no problem with loading libraries anymore.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.