RStudio crashes with using python/reticulate

Hi All,

R version 3.6.1
RStudio Version 1.2.5033
reticulate version ‘1.14.9001’
‘rmarkdown’ version 2.1
‘knitr’ version 1.28
anaconda python version 3.7.6

I have set up the python using the use_python(path)

When I add a new python chunk and start type import pandas the Rstudio crashes every single time. Even if I don't try to import and simply print(1) it crashes when the chunk is executed.
The enclosed screens have other details.
Can someone help advise what is causing this crash?

I retried the same with Preview RStudio-1.3.878 and daily build RStudio-1.3.879 and still the same crash.
I don't even have to execute the python chunk!. Just start typing "import pand" for "import pandas as pd" and it's crashed.

I tried to find the logs in all the regular places on MacOsx and don't find any.

Can someone please advice?

Vinay

Exactly the same problem here. Any help would be greatly appreciated.

Does reinstalling pandas make a difference? E.g.

reticulate::py_install("pandas", pip = TRUE)

After further debugging it looks to be an issue(for me atleast) with the "reticulate" package.I had the dev version installed.

I removed that and installed from CRAN v 1.14 and its all working correct now.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.