Rstudio Desktop can't find build tools

When I run the commands below in the R GUI (version 3.5.2):


I get the following output:

> \> has_build_tools(T)
Scanning R CMD config CC...
'.exe' does not exist
Scanning path...
Scanning registry...
Found C:/RBuildTools/3.5 for 3.5 
Rtools version 
[1] TRUE

However, when I run the same commands from within the RStudio desktop client (Version 1.1.463), I get a different result. I get a message box asking me if I'd like to install build tools. I click "no" since I believe I have the build tools, and the console returns the following:

> \> has_build_tools(T)
[1] FALSE 

Do you have any better luck with the preview release of RStudio?

I've solved the issue. Turns out my company's anti-virus program was preventing Rstudio from detecting build tools. We have resolved the issue internally.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.